Broke EMI finger off speaker enclosure, cause of my signal issue?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by calvy, Apr 23, 2011.

  1. calvy macrumors 65816

    Joined:
    Sep 17, 2007
    #1
    I know, from the title you are already thinking I'm an idiot. And maybe I am :) but I've got plenty experience taking things like this apart. And I lost no screws and got the phone together perfectly in every other aspect. But...you know the black piece on towards the bottom of the phone that houses the speaker and mic. It's called the Speaker Enclosure in the ifixit tear down guide. Well, I broke one of the EMI fingers off this thing when trying to put it back in the case properly. I had no idea how flimsy those EMI fingers were, and didn't realize I needed to be more gentle with those. Oops.

    Anyway, the finger I broke is the one furthest away from the logic board.

    I reassembled everything and all is great, except that now the phone never gets 4 bars of signal. It maxes out at 3.

    So, is it because of the broken finger? Or did I not clean some other metal contact well enough, thus causing my signal issues? And what's the best way to get this phone back in working order? Can the part be bought cheaply somewhere?
     
  2. calvy thread starter macrumors 65816

    Joined:
    Sep 17, 2007
    #2
    actually it looks like the speaker enclosure can be bought for 20 bucks from ifixit. Is that the fix I need? I could also probably take it into an apple store and play dumb. But that's not exactly ethical.
     

Share This Page