Bug: incorrect attribution (“I never said that!”; “He never … she never …!")

Discussion in 'Site and Forum Feedback' started by grahamperrin, Jun 2, 2015.

  1. grahamperrin, Jun 2, 2015
    Last edited: Jun 3, 2015

    grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #1
  2. arn macrumors god

    arn

    Staff Member

    Joined:
    Apr 9, 2001
    #2
    It looks like you manually edited the quote and accidentally used a curly quote to try to close the first quote. XF didn't recognize it so wrapped the whole thing as a quote

    Screen Shot 2015-06-03 at 2.21.55 AM.png
     
  3. grahamperrin thread starter macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #3
    That's odd. I have no recollection of editing the markup of either quote. No reason for me to do so.

    At the time of the problem I used prerelease builds of OmniWeb and Yosemite. I'll try to reproduce the problem.
     
  4. grahamperrin thread starter macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #4
    Bug reproduced with OmniWeb 6.0 test (v626 r234821) on Yosemite. I’ll try to reproduce without OmniWeb. Give me five, then I’ll share the details.
     
  5. OllyW Moderator

    OllyW

    Staff Member

    Joined:
    Oct 11, 2005
    Location:
    The Black Country, England
    #5
    Seems to work properly in Safari.
     
  6. grahamperrin thread starter macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #6


    Agreed.

    I can’t find anything autocorrect-specific in this build of OmniWeb, but the automated curl of the quote does occur, reproducibly. At this time I no longer suspect a problem around XenForo, but for the record, here are the steps.


    Actions

    01) with OmniWeb, use the contextual menu method of adding a selection from a post (not a post in its entirety) for multiquote purposes

    02) with a different post in the same topic, repeat step (01) – select, observe the drop-down, point and click + Quote

    03) page/scroll down until the reply field and its buttons are visible

    04) click ‘Insert Quotes…’

    05) click to position the cursor to the right of the first closing ]

    (between that markup character, and the first character of the quote)​

    06) key combination Option-; followed by key Spacebar



    Expected

    07) an ellipsis … and a space, with no change to the " that precedes the ]


    Actual result

    07) curl of the double quotation mark within the markup …

    ”]…​


    Observations, thoughts

    I can avoid the problem by disabling smart quotes in the Keyboard pane of System Preferences.

    With that workaround I'm tempted to mark this topic as resolved. However I'd like to test in a few other browsers to see whether the inappropriate curl is reproducible without OmniWeb.
     
  7. grahamperrin thread starter macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #7
    [QUOTE="OllyW, post: 21399326, member: 59727”]… properly in Safari[/QUOTE]

    Reproduced with Maxthon 4.5.2 from the App Store, on Yosemite.

    I suspect that when smart quotes and dashes are enabled, in System Preferences, Safari does not respect that user preference.
     
  8. grahamperrin thread starter macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #8
    Now without using the multiquote feature of XenForo, testing, with Safari in Yosemite, and with smart quotes and dashes enabled: "… its fleece was white as snow." I said "nothing of the sort". Neither cutting/copying nor pasting, simply typing ahead "this" and "that" and hey ho, none of the quotes that I type are smartened by the operating system. So, I should treat that as a bug in Safari. It's off-topic, but it explains why the problem is not reproducible with that browser.
     
  9. grahamperrin thread starter macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #9
    Now with with Maxthon on Mavericks, OS X 10.9.5:

    Also reproducible with relatively old OmniWeb 6.0 test (v625 r219164) on the same Mavericks.

    Also I can reproduce the troublesome curl if I paste (for example) the following text into a draft in a forum that uses phpBB –

    Code:
    [QUOTE="OllyW, post: 21399326, member: 59727"]Seems to[/QUOTE]
    – and then perform the same edition (ellipsis and a space) to the beginning of the text, not the markup.

    I performed a few other tests, which I’ll not detail here.


    Low priority: a question, to MacRumors staff who had knowledge of vBulletin behaviours

    A long shot.

    Is it possible that where the vBulletin environment was tolerant of a single smartened quote within markup, XenForo is strict?

    Specifically: strict about the nonmatching pair – opening " upright (non-smartened), closing ” curled (smartened).​

    I ask that because I very often used OmniWeb with MacRumors forums before shift to XenForo, and I find it difficult to imagine that a mismatch never occurred in that vBulletin environment.
     
  10. arn macrumors god

    arn

    Staff Member

    Joined:
    Apr 9, 2001
    #10
    @grahamperrin it's possible vBulletin accepted curly quotes as an alternative.
     

Share This Page