Call of Duty 4 Multiplayer LAGS & BUGS AFTER 10mins OF GAMEPLAY!?

Discussion in 'Mac and PC Games' started by MacBook MH, Nov 4, 2010.

  1. MacBook MH macrumors member

    Joined:
    Mar 7, 2009
    #1
    Hi everyone,
    me and my younger brother play Call of Duty 4 (1.7) Multiplayer. We have exact same MacBooks (Aluminium unibody late 2008) even bought at the same time. After we join the multiplayer game, everything works fine. But in 10 minutes, my brothers starts totally lagging. It still works, but slow, and the game is unplayable. We have set up the same controls, options, everything including graphic settings. No success. We tried to make our own lan game, so we find out if the problem is our internet connection. Still same result. Lagging. The next thing we tried is to create a game on my brothers Mac, but we didnt join in MY own macbook, so only one player (he) was running around the multiplayer game for 10 minutes. Even then it kept on lagging on all maps.

    We also tried reinstalling Mac OS X (snow leo) and installed the game completly new. Nothing, only lags. WHAT THE HELL IS WRONG? WE HAVE THE EXACT SAME COPY OF THE GAME, THE SAME VERSION, THE SAME MACBOOK AND THE SAME SYSTEM CONFIGURATION?!!

    * PLEASE HELP *
     
  2. roadbloc macrumors G3

    roadbloc

    Joined:
    Aug 24, 2009
    Location:
    UK
    #2
    The 10.6.4 update has totally broken COD4 for me. I'm guessing that may be the root of all you're problems as well.

    Hopefully 10.6.5 will fix it.
     
  3. MacBook MH thread starter macrumors member

    Joined:
    Mar 7, 2009
    #3
    But we both are on 10.6.4 ... what is wrong with 10.6.5 ?
     
  4. Ace134blue macrumors 6502a

    Ace134blue

    Joined:
    Sep 17, 2009
    #4
    Is his the exact same specs as yours? How much ram does he have? Are you both using the exact same graphic settings? It could be running choppy because of a memory leak.
     
  5. MacBook MH thread starter macrumors member

    Joined:
    Mar 7, 2009
    #5
    Yes ... we use both the same graphic setting, same graphic cards.... the macbooks are same! totaly same model.... it is really strange that on my MacBook (i have it full of crap...) it runs perfectly, and on his MacBook (freshly reinstalled) it lags... btw. what exactly do you mean by memory leak/how do i solve it?

    our RAM is 2GB
     
  6. MacBook MH thread starter macrumors member

    Joined:
    Mar 7, 2009
    #6
    Please help! I also forgot to say that if you play the game for 10 min and then restart it, it works for another 10 min without lagging...
     
  7. skeley69 macrumors member

    Joined:
    Dec 28, 2003
    Location:
    England, UK
    #7
    can i ask if you managed to solve this?

    ive recently noticed this problem on my macbook pro playing LAN with my brothers and about 5 mins in a game gameplay starts to lag/drag/whatever.

    it never used to do this and its become quite annoying. i have downloaded some mods such as pezbot/k3 but so have my brothers and their macbook pros arnt having any problems soooooo.....

    let me know

    many thanks
     
  8. jason221 macrumors 6502

    Joined:
    Jun 26, 2009
  9. MacBook MH thread starter macrumors member

    Joined:
    Mar 7, 2009
    #9
    I didn't solve it... What we did is lowering graphics settings and going into Stand By mode (closing the lid) when it starts lagging...
     
  10. paddypractice macrumors newbie

    Joined:
    Dec 22, 2011
    #10
    stupid but simple

    this sounds silly but what is your brothers power saver settings. does he have the screen set to go dark after 10 mins or for screen saver to come on.
    Sounds ridiculous but because of poor programming, when i have had games up and running, for some reason they seem to be separate from the computer itself and my desktop carries on as usual
     

Share This Page