Calls go straight to voicemail - phone requires restart

Discussion in 'iPhone' started by cellocello, Sep 29, 2008.

  1. cellocello macrumors 68000

    cellocello

    Joined:
    Jul 31, 2008
    Location:
    Toronto, ON
    #1
    So last night I was hanging with the female, expecting a call from a mutual friend to come over and make dinner. The hours passed, we just chilled and I assumed something came up and he didn't get a chance to call.

    Then, hours later, on the iPhone iteself, I noticed a facebook message to the effect of "WTF dude. Your phone's off. Guess I'll talk you later .... jerk" from my buddy.

    Restarted the phone, and boom - it downloads like 4 txt messages and 2 new voicemails. I was pretty upset that not only did I "ditch" my friend, but that my iPhone let me down so hardcore.

    I mean ... sure, delayed voicemail sucks and everything, but to simply NOT get it all all is even worse. Is this common? Has this happened to anyone else? Should I be restarting my phone once a day or something?
     
  2. andyblila macrumors 65816

    andyblila

    Joined:
    Jul 8, 2008
    Location:
    On My iPhone, or my iPad?
    #2
    It has happened to me as well. I try and restart my phone at least every other day.
     
  3. dccorona macrumors 68020

    dccorona

    Joined:
    Jun 12, 2008
    #3
    it happend to me too
    several times
    once requiring a complete system restore to resolve

    this should be fixed, because it is important that my phone work AS A PHONE before anything else

    of course, all the problems were with 2.0
    havnt had an issue with 2.1 yet, but sounds like you have, so its obviously an issue
     
  4. whlphil macrumors member

    Joined:
    Sep 6, 2008
    #4
    Even worse i seem to be stuck in an eternal restore loop!

    Ive had something similar happen on my phone today, in the middle of a call it dropped it not that unusual it tends to do this about 2 or 3 times a day seems worse on 2.1 than it was 2.0.2!

    So when it dropped the call I called straight back only to get the engaged tone, called someone else the same, looked at the phone 5 bars but no carrier speed not GPRS, E or 3G just blank. All the other functions seemed to work (obviously no data connections/txt) - strange!

    So i tried the usual, turn off restart - no, soft reboot restart - no, pull sim out while turned on (on the advice of o2 in UK apparently it resets the connection at there end) nope no change. So last resort Restore....

    So everything boots up fine i receive a call and some messages come in. I wrongly assume that everythings OK and put back in my pocket, when i come to make next call i look at home screen to my disbelief half my apps have disappeared and it appears to have reset itself back to about 3 weeks ago and its missing the speed indicator again and all outgoing calls are now just the engaged tone...

    So now im restoring again if this doesnt work im throwing it out the window!

    The one thing the phones got to do is be a phone! its a great product but im seriously losing my patience with it at the moment, ive had the 2.5g and then the new 3g both since launch in the UK but this is getting beyond a joke and is starting to effect my work and thats one thing i wont stand for, I really hope 2.2 gets this sorted once and for all because im running out of hair to tear out!!

    Anybody else had this problem?
     
  5. cellocello thread starter macrumors 68000

    cellocello

    Joined:
    Jul 31, 2008
    Location:
    Toronto, ON
    #5
    Well ... last night has the first time happened so hardcore.

    I've had delayed voicemails before, but I've never had it that nothing phone related got thought until a restart. Pretty lame, if you ask me.

    I should point out that I was able to make out going calls -- which is what further confused me, since I assumed things were working as expected.
     

Share This Page