Can’t connect to App store

Discussion in 'macOS Mojave (10.14)' started by groxx, Jun 6, 2018.

  1. groxx macrumors newbie

    Joined:
    Jun 5, 2018
    #1
    I am currently abroad, but live in the US and have a US Apple ID. When I go to App Store, it seems to open fine, but when I try to download something, it tells me that im in the wrong country for this Apple ID and switches me to the US store, which also seems to work fine. Then, when I try to download something again, I get an error saying “Cannot connect to App Store”.

    Does anybody have a solution to this?
    I would really appreciate it.
     
  2. Stefdar macrumors newbie

    Stefdar

    Joined:
    Feb 4, 2012
    #2
    It's in the Mojave release notes.
    Open Terminal
    defaults delete com.apple.appstore.commerce
    Open appstore, sign in, hit retry once or twice, it will start working.
     
  3. groxx thread starter macrumors newbie

    Joined:
    Jun 5, 2018
    #3

    I missed that. It works now. Thank you so much!
     
  4. pat rogers macrumors newbie

    pat rogers

    Joined:
    Oct 1, 2018
    #4
    Nope, doesn't work.
     
  5. ButteryScrollin macrumors 6502a

    Joined:
    Jul 29, 2014
    #5
    this fixed the 'Cannot Connect to App Store' message, but now I get 'cancelled' when trying to download.
     
  6. matthk macrumors newbie

    matthk

    Joined:
    Sep 17, 2004
    Location:
    Melbourne, Australia
    #6
    The terminal tip worked only temporarily for me. :-(

    So I'm trying this one from TechRadar:
    "...First, open the KeyChain Access app and click on 'System Roots'. You'll see an entry for 'DigiCert High Assurance EV root CA'. Double-click it, then expand where it says ‘Trust’.

    From there, change 'When using this certificate' from 'Use System Defaults' to 'Never Trust’.

    Now, restart the Mac, and reopen KeyChain Access. Go back to where you were, and change 'When using this certificate' back to 'Use System Defaults’.

    You should now be able to access the App Store..."

    https://www.techradar.com/au/how-to/macos-1014-mojave-problems-how-to-fix-them
     
  7. ButteryScrollin macrumors 6502a

    Joined:
    Jul 29, 2014

Share This Page