Can’t Control TV Volume from iPhone/Remote app

bgrace

macrumors regular
Original poster
Oct 1, 2008
159
28
When the lock screen or control center on my iPhone shows content playing on my Apple TV, the volume slider is grayed out. I also can’t control volume using the volume rocker while the Apple TV Remote app is open. I have a simple setup: just an Apple TV and a Samsung TV connected by an HDMI cable. HDMI-CEC is enabled and Volume Control is set to “Auto via HDMI” on Apple TV. HDMI-CEC is working for other functions, including turning on/off the Samsung TV when I wake/sleep Apple TV, so not sure why volume control isn’t working. Am I missing something?
 

waw74

macrumors 68040
May 27, 2008
3,173
194
to confirm it's really using CEC, "hide" the Siri remote under a blanket or something and try to change the volume

I've got 2 Appletv (a 4 using iR to control the tv, and a 4k using CEC)

on the tv with IR, there is a greyed out volume slider
on the tv with CEC, there are 2 volume buttons. (no slider to be seen)
 

RomanEmpire

macrumors member
May 29, 2018
97
74
Vienna
I have the same issue with my LG E7. the apple tv remote seems to connect via IR only. This means I cannot change volume using HDMI-CEC.
Can I somehow force the apple tv to use HDMI-CEC instead of IR?
 

bgrace

macrumors regular
Original poster
Oct 1, 2008
159
28
Update: I connected a soundbar to my TV via HDMI (ARC) and now I am able to control the volume from my iPhone. Didn't work when I was just using my TV speakers for audio.

Can I somehow force the apple tv to use HDMI-CEC instead of IR?
When I just have my Apple TV playing audio through my TV speakers, I don't get the option to change volume control to HDMI (Apple TV Settings > Remotes and Devices > Volume Control). The only way I've been able to do this is to wake the Apple TV using the Apple TV Remote app on my iPhone instead of the physical Apple TV remote which uses IR. The Volume Control setting changes to "Auto via HDMI" but for some reason still does not allow me to control the volume from my iPhone. Once I use the physical remote, it switches back to "Auto via IR." You may want to try this to see if you have better luck.