Can’t play WoW in clamshell mode.

digitaldave

macrumors regular
Original poster
Apr 6, 2006
123
9
I have a problem with World Of Warcraft that I hope someone can help with...

When I try to play WoW on my MacBook Pro in clamshell mode in an external monitor, it loads up the Blizzard app correctly, but when it loads the main WoW app, it runs it on the internal screen, even though the screen isn’t visible. I can confirm the game is running by using cmd-tab, but as soon as i select the actual game, it switches back to the internal display and the external one goes blank again. The only way I can get it to work at all with the external monitor is to run the machine open, launch the game, and manually select the external display from the drop down in the settings of the game, whilst leaving the MacBook Pro open.

I have also tried starting the game in clamshell mode, running in windowed mode, not windowed full screen, but get the same problem :-(.

I’m certain that clamshell mode is working at least partly as intended, as when I go to Displays in System Preferences, I only see the external monitor, and other apps seem to work fine.

Is this normal, or is there something I can do to get it working the way I think it should?

Thanks.
 

vertical smile

macrumors 68040
Sep 23, 2014
3,938
5,139
I don't have a solution for you, but a suggestion.

You should try the battle.net forums. The Mac technical support forum is really helpful and is monitored by blizzard techs.
 

digitaldave

macrumors regular
Original poster
Apr 6, 2006
123
9
Thanks for the suggestion. Unfortunately, I’m in the UK, and the EU forums don’t have a Mac support section. I have posted in the general support forum, but so far no luck .
 

digitaldave

macrumors regular
Original poster
Apr 6, 2006
123
9
Just thought I'd post an update to this...

I did some investigating, playing with different settings for desktop and game resolution. When the desktop was set to 1920x1080, I could set the game resolution to anything - I tried 1920x1080, 2560x1440 and 3840x2160 (it's connected to a 4K monitor) and they all worked as expected. The same with the desktop set to 3840x2160, I could set any in game resolution, and they all worked. The problem came when I set the desktop resolution to 2560x1440 - when set to that, the game would always fail to run on the external display. So to get it working, it looks like the desktop and game resolution need to be an integer multiple of each other (i.e. 1x, 2x etc). Problem sort of solved... except I usually run the desktop at 2560x1440 :-(.

I also managed to get it working correctly if I launched the game using the 'low resolution' option, but that makes things a little bit blurry (it's not a massive thing, but I can notice it).

So I now know how I can run the game in clamshell mode - either by manually changing the desktop resolution, or running slightly blurry.

:)