Carrier Can’t send messages

Discussion in 'iPhone' started by SoN1NjA, Feb 11, 2018.

  1. SoN1NjA macrumors 68000

    SoN1NjA

    Joined:
    Feb 3, 2016
    Location:
    the pool
    #1
    Hi all,

    I got a 2nd phone number recently and whenever I’m in group chats I like to have my Verizon number and AT&T in the chat

    Unfortunately I can’t seem to send messages from my AT&T Prepaid, as they all show the ! alert

    Strangely I can receive all of the messages, make calls, and use mobile data

    Help?
     
  2. codefive89 macrumors newbie

    Joined:
    Jan 21, 2018
    #2
    Try resetting network settings. In the settings app go to general then reset then tap on reset network settings to update carrier and network settings. It will then restart device and you will need to enter back in wifi password s and connect. If that doesn't work then reset all settings. Hopefully the network reset should reolve this issue
     
  3. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #3
    Check your iCloud settings. Most likely you didn’t allow sending from your AT&T number.
     
  4. mikzn macrumors 65816

    mikzn

    Joined:
    Sep 2, 2013
    Location:
    Vancouver
    #4
    check on your iPhone that both numbers are visible and active in Settings < Messages < Send and Receive

    there should be a list of emails and devices (iPhones - iPads) that are connected to iMessage

    if both phone nubers don't show there you will have to check both phones to make sure all the settings are correct
     
  5. SoN1NjA thread starter macrumors 68000

    SoN1NjA

    Joined:
    Feb 3, 2016
    Location:
    the pool
    #5
    Resetting Network Settings didn’t work

    Where would that be? I don’t see something like you’re mentioning

    This isn’t for iMessage
     
  6. mikzn macrumors 65816

    mikzn

    Joined:
    Sep 2, 2013
    Location:
    Vancouver
    #6
    ok - might help if you explain what the "chats" are?

    the i alert sounds like iMessage - is this another message service?
     
  7. SoN1NjA thread starter macrumors 68000

    SoN1NjA

    Joined:
    Feb 3, 2016
    Location:
    the pool
    #7
    SMS and MMS, it’s a group chat where not everyone has an iPhone
     
  8. mikzn macrumors 65816

    mikzn

    Joined:
    Sep 2, 2013
    Location:
    Vancouver
  9. SoN1NjA thread starter macrumors 68000

    SoN1NjA

    Joined:
    Feb 3, 2016
    Location:
    the pool
    #9
    the Messages app, when I said they weren’t iMessages I meant they’re not blue bubbles, iMessage is a service not an app

    Here’s what I see, and that message from Josh is also me on my Verizon phone

    [​IMG]
     
  10. mikzn macrumors 65816

    mikzn

    Joined:
    Sep 2, 2013
    Location:
    Vancouver
    #10
    if you want to consolidate messages from both phones ( i also have 2 separate iPhones with separate providers) you will have to make sure they are both on the same apple id and that you have both phones configured as I mentioned above "both numbers are visible and active in Settings < Messages < Send and Receive"
     
  11. SoN1NjA thread starter macrumors 68000

    SoN1NjA

    Joined:
    Feb 3, 2016
    Location:
    the pool
    #11
    As I’ve said, the Send and Recieve screen is for iMessages, I’ve got iMessage working just fine

    I want both of my separate numbers in the group chat, but I want to be able to send from my AT&T also
     
  12. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #12
    Settings > Messages

    Scroll down until you see Send & Receive

    Go in there and see what addresses are enabled. Phone numbers are addresses as well.
     
  13. SoN1NjA, Feb 11, 2018
    Last edited: Feb 11, 2018

    SoN1NjA thread starter macrumors 68000

    SoN1NjA

    Joined:
    Feb 3, 2016
    Location:
    the pool
    #13
    Here ya go

    [​IMG]

    please don’t contact me

    update: this message previously had my phone numbers shown, but now that information is redacted (indicated by the black)
     
  14. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #14
    I suggest you grey out your numbers... It looks in order as you are receiving well, but your sending is off. Try the second number and try sending a text again.
     
  15. SoN1NjA thread starter macrumors 68000

    SoN1NjA

    Joined:
    Feb 3, 2016
    Location:
    the pool
    #15
    It works!

    I apologise to the guy above for not following his advice and wasting his time

    I also party blame Apple for not communicating what those options do, and also allowing stuff like that to happen

    I wish I could have it set on the Verizon number though as I don’t want to hand my AT&T number out if I don’t have to
     
  16. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #16
    Glad to help.
     

Share This Page

15 February 11, 2018