Can Anybody Help Me to put my MBP to sleep faster?

Discussion in 'MacBook Pro' started by XTRanger, Feb 12, 2008.

  1. XTRanger macrumors member

    Joined:
    Jun 24, 2007
    #1
    I recently purchased a MBP, 2.6GHz. The machine is great, but one problem that I am having is that the machine takes over 50 seconds to go to sleep, from the time i close the lid.

    I have seen my friends MB going to sleep under 4 seconds from the time they close the lid-- and thats how it was with the G4s (i believe).


    Can anyone tell me what the heck is wrong with my computer that it takes so long to go to sleep?
     
  2. squeeks macrumors 68040

    squeeks

    Joined:
    Jun 19, 2007
    Location:
    Florida
    #2
    mine does the same thing not sure about this new update or not
     
  3. aross99 macrumors 68000

    aross99

    Joined:
    Dec 17, 2006
    Location:
    East Lansing, MI
    #3
    The new machines have "Safe Sleep", which write the contents of your memory to disk, and then turns off the computer. The older computers just went to sleep, and would lose informaiton if they lost power during this time.

    Not sure though if the new machines go into "Safe Sleep" immediately, or after certain period of time...
     
  4. XTRanger thread starter macrumors member

    Joined:
    Jun 24, 2007
    #4
    would this safe sleep setting increase the time for the computer to go to sleep by 45 seconds? I looked around, and found out a way to disable safe sleep by using the Terminal.

    That did not seem to help me... the transit time to sleep is still at ~50seconds. Anything else I can try?
     
  5. squeeks macrumors 68040

    squeeks

    Joined:
    Jun 19, 2007
    Location:
    Florida
    #5
    reset pram lol never know might help

    google: (resetting pram)

    or repair permissions in disk utility
     
  6. PCWizKid macrumors newbie

    PCWizKid

    Joined:
    Feb 12, 2008
    #6
  7. XTRanger thread starter macrumors member

    Joined:
    Jun 24, 2007
    #7
    I am not looking for running the computer when I close the lid. I want the computer to go to sleep quicker- i.e. in 4-5 seconds, instead of taking 50 seconds.
    I have performed a PRAM reset, did not help
     
  8. zephead macrumors 68000

    zephead

    Joined:
    Apr 27, 2006
    Location:
    in your pants
    #8
    I don't know if this is what you already typed into the Terminal, but I'll ask just to make sure.
    Code:
    sudo pmset -a hibernatemode 0
     
  9. Freyqq macrumors 68040

    Joined:
    Dec 13, 2004
  10. XTRanger thread starter macrumors member

    Joined:
    Jun 24, 2007
    #10
    yep thats what i typed in terminal, but it doesnt seem to make a difference for some reason. Are there any other settings that i need to change?
     
  11. fsckminix6 macrumors regular

    Joined:
    Sep 14, 2006
    Location:
    Chicago (847)
  12. Lone Deranger macrumors 65816

    Lone Deranger

    Joined:
    Apr 23, 2006
    Location:
    London
    #12
    hehe... this is not windows world we're talking about you know. No restart required for this sort of thing. :)

    XTRanger, make sure you provide your sudo (super user) password correctly at the terminal prompt when you are asked to do so. Otherwise the sudo command won't get executed.

     
  13. XTRanger thread starter macrumors member

    Joined:
    Jun 24, 2007
    #13
    Yep. Didnt help.


    I entered it correctly. even when i do "$ pmset -g | grep hibernatemode" to check for the current state, it says that its in mode 0, but it still takes time to go to sleep, as if nothing changed.
     
  14. anirban macrumors 6502a

    anirban

    Joined:
    Jan 9, 2007
    Location:
    Houston, TX
    #14
    I also seem to have the same issue.


    I am running Tiger though, so maybe that may have something to do with it. What OS are you running?
     
  15. Bunsen macrumors member

    Joined:
    May 1, 2007
    Location:
    Orlando FL
    #15
    Are you sure it's actually taking that long to go to sleep, or are the fans just on for 50+ seconds? When I close my lid, it takes a couple of seconds for the screen to turn off, then in another couple, I hear the HD park: meaning for all intensive purposes, the computer is asleep. However, the fan keeps spinning for another 10 or so seconds, depending on how hot it was.
     
  16. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #16
    10.4.10 seems to take longer to sleep than 10.4.11.

    More ram / apps used = longer to safe sleep.

    Tried changing hibernation mode on Santa Rosa 17" 2.4ghz but didn't work for me either.

    Do you have Apple Remote Desktop 2 installed?
     
  17. mchank macrumors regular

    Joined:
    Feb 26, 2006

Share This Page