Can Anyone Here Read a Crash Log?

Discussion in 'General Mac Discussion' started by tjwett, Mar 20, 2003.

  1. tjwett macrumors 68000


    May 6, 2002
    Brooklyn, NYC
    I am having major iTunes trouble after installing the 1.2.6 iPod update. This is what I get when I try to launch iTunes. If you can make any sense of this I would love to hear it. Thanks.


    Date/Time: 2003-03-20 12:43:17 -0500
    OS Version: 10.2.4 (Build 6I32)
    Host: Theodore-Wetts-Computer.local.

    Command: iTunes
    PID: 652

    Exception: EXC_BREAKPOINT (0x0006)
    Code[0]: 0x00000001Code[1]: 0x8fe01280

    Thread 0 Crashed:
    _#0 0x8fe01280 in halt
    _#1 0x8fe0329c in load_library_image
    _#2 0x8fe06134 in load_images_libraries
    _#3 0x8fe026e8 in load_executable_image
    _#4 0x8fe01410 in _dyld_init

    PPC Thread State:
    __srr0: 0x8fe01280 srr1: 0x0002f030 vrsave: 0x00000000
    ___xer: 0x20000000 lr: 0x8fe0a064 ctr: 0x8fe28f78 mq: 0x00000000
    ____r0: 0x00000004 r1: 0xbffffbb0 r2: 0x24008280 r3: 0x000000bb
    ____r4: 0x00000000 r5: 0x000000bb r6: 0x0000290a r7: 0x726e6f20
    ____r8: 0x66696c65 r9: 0x00000000 r10: 0xbffff92b r11: 0x00000026
    ___r12: 0x8fe71ae3 r13: 0x00000000 r14: 0x00003a50 r15: 0x00000000
    ___r16: 0xbffffe54 r17: 0x00000001 r18: 0x00001614 r19: 0x00003664
    ___r20: 0x00000001 r21: 0x00000000 r22: 0x00000000 r23: 0x00000000
    ___r24: 0x8fe4b3e0 r25: 0x00000002 r26: 0x00000002 r27: 0x00000000
    ___r28: 0x00001900 r29: 0x00000000 r30: 0x8fe484d8 r31: 0x8fe09ecc

    * *********
  2. MacsRgr8 macrumors 604


    Sep 8, 2002
    The Netherlands

    Sorry to be of no help, but I wanted to mention this:
    Unix logs everything, they said. So whatever happens to your machine, and by whom it's documented right there in your /var/log.
    No more weird "Error of type 2 occured, you must restart.. and so on" messages, they said.
    No Winbloze Blue Screens of death, they said.
    Nope, but I have, as you, seen these error logs and have tried to figure out what they mean. And they express the same errors as those Blue Screen of Death messages do. Some kind of failure reading or writing to or from memory. Right.
    So what do we do? Yep, same as in OS 9. Delete the prefs, (OK, ~/library/Prefernces/ instead of System Folder:prefernces), try reinstalling, and so on.
    Anyway, good luck!
    Edit: Just curious... you have tried repairing disk permissions?
  3. tjwett thread starter macrumors 68000


    May 6, 2002
    Brooklyn, NYC
    Re: hmmm

    hey, yeah i fixed the permissions a million times with no luck. the app (iTunes) never launched again. i wound up having to do a Software Restore and lost alot of data(I always forget to backup something in the confusion. no one at apple could even help me out. it happened from the 1.2.6 iPod updater so i went back to 1.2.1 and i'm staying there. it's a bummer but i luckily got my Jaguar disks back and was able to install Jag again. It was actually quite a nice change being in OS 9 for a week. really fast. but we all must move on i suppose.
  4. timbloom macrumors 6502a


    Jan 19, 2002
    This is not scientific or anything, but what I have noticed from extensive tech work is that usually when you get a whole bunch of numbers liike that in the backtrace without the mention of a file or service, it usually turns out to be hardware. This is not always the case, but seems to be more than 1/2 the time.

    What I would just assume from your problem is that there is just something wrong with the software on your iPod. Try reinstalling the iPod update first.

Share This Page