Can I install and earlier version of iphone's firmware? Help, I can't use my phone!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by katelmesser, Sep 28, 2008.

  1. katelmesser macrumors newbie

    Joined:
    Sep 28, 2008
    Location:
    Cincinnati
    #1
    I recently bought an iphone used, unlocked. The latest firmware was not installed so I installed then was going to unlock the phone once updated. Well, I didn't realize that izphone is still working on the latest firmware. So, I can't use my sim card and the phone is now basically useless unless I can maybe reinstall the earlier version (from somewhere?trusted source?) and try to unlock again. I'm on an iMac 10.4.11 so any recommended downloads should be compatible. I

    Anyone following me here? I hope this makes sense and some kind soul with the knowledge to help me will come along! :)
     
  2. pol0001 macrumors 6502

    pol0001

    Joined:
    Apr 15, 2008
    Location:
    London
    #2
    Use quickpwn. There is a sticky on how to unlock/jailbreak your iPhone. I accidently restored my unlocked iphone and the unlock was gone. I ran Quickpawn to unlock and jailbreak it again and used the last backup in iTunes to transfer my settings/data/apps to the phone again.
    I had a problem with the battery at first. But putting the phone in DFU mode (w/o my mac) and than restarting it solved that issue for me.
     
  3. katelmesser thread starter macrumors newbie

    Joined:
    Sep 28, 2008
    Location:
    Cincinnati
    #3
    Were you using the 2.1v on iphone and 8.0v on itunes?
     

Share This Page