can I upgrade to OS4.0? unlocked iPhone 3G 3.0 7A341 firmware 04.26.08

Discussion in 'Jailbreaks and iOS Hacks' started by gh0001, Jul 3, 2010.

  1. gh0001 macrumors member

    Joined:
    Sep 10, 2008
    #1
    I have an unlocked iPhone 3G with 3.0 7A341, firmware 04.26.08.

    can I upgrade to 4.0 and JB and unlock it again? If so any pitfalls to avoid? Thanks a bunch.
     
  2. Greg M macrumors 6502

    Joined:
    Jul 13, 2008
    #2
    Upgrade using pwnage so that you'll preserve the baseband that you have. Also when upgrading don't enable the multitasking, wallpaper and batt percentage. They really bog down the 3g.

    With redsn0w I believe that you'll loose the baseband that you have so that's why I wouldn't use that.

    Go to iClarified for the instructions.

    BTW, I've upgraded 2 3g phones with your baseband to 4.0 using pwnage with no problems. I've also upgraded a 3gs with the same baseband to 4. If you follow the instructions then it will work. If you have any questions or are unsure about even the smallest detail then ask first. Better to take a chance on sounding dumb then to mess up the phone.
     
  3. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #3
    Go to DevTeam blog
    Use Redsnow
    For a 3G, most are saying Multi-tasking and wallpapers slows the 3G way down.
     
  4. sash macrumors 6502a

    sash

    Joined:
    Nov 23, 2004
    #4
    It’s possible and it’s easy, but in many cases 3G gets way to slow after upgrade. I’ve already downgraded my iPhone.
     
  5. SavMBP15 macrumors 6502

    Joined:
    Mar 26, 2010
    #5
    But with the new Ultrasn0w out that doesn't matter anymore, especially with a 3G, right?
     
  6. gh0001 thread starter macrumors member

    Joined:
    Sep 10, 2008
    #6
    thank you guys. I am not sure what tool I should use. I will check them out.

    for 3G that upgraded to 4.0, is it still too slow if you disable multitasking and wallpaper?
     
  7. Greg M macrumors 6502

    Joined:
    Jul 13, 2008
    #7
    When the Dev team says that 04.26.08 is preferred then I'll go the route that preserves that baseband.
     
  8. Greg M macrumors 6502

    Joined:
    Jul 13, 2008
    #8
    No, I don't think it was any slower then 3.1.2 was. I think they both are slow on the 3g. Just leave multitasking disabled.
     
  9. cwrenn macrumors newbie

    Joined:
    Jul 4, 2010
    #9
    sorry for piggy backing on the OPs issue, but I didn't want to spam the board with a very similair query..

    basically I have the same set up as the OP (i.e. 3.0 7A341, firmware 04.26.08 and old bootrom), jb'd and unlocked, and I'm trying to figure out the best path to IOS4.

    should I restore using a custom ipsw (e.g. as available on sinfuliphone), or create my own using sn0wbreeze? will i lose my mms etc.?

    sorry again for the questions, and the piggybacking
     
  10. gh0001 thread starter macrumors member

    Joined:
    Sep 10, 2008
    #10
    cwrenn, no problem. I want to know the answers to your questions too.

    Looks like pwnage is only available in Mac, so if I want to preserve my baseband I need to use a Mac machine? thanks.
     
  11. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #11
    Since Ultrasn0w has been updated to work with all the newer basebands, keeping 4.26.xx is not important as it once was.
     
  12. cwrenn macrumors newbie

    Joined:
    Jul 4, 2010
    #12
    sorry, left out the important part of my query...!

    instead of 3G, I have 3GS...

    again,apologies...

    greg, would you recommend holding off using sn0wbreeze until the Windows equivalent of Pwange is available due to the baseband issue?
     
  13. lokster macrumors 6502

    lokster

    Joined:
    Feb 7, 2010
    #13
    what i would do is

    update using the latest redsnow to jailbreak
    download and install ultrasnow through cydia

    easy
     
  14. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #14
    Works for 3G, not for 3GS
     
  15. Greg M macrumors 6502

    Joined:
    Jul 13, 2008
    #15
    There are many more people a lot more knowledgable then me about this. I'm just passing along my experiences about this. With the 3gs you have to be more careful about finding out all the details before you attempt a JB and UL. I messed up 2 3gs iphones because I wasn't fully prepared :(

    I'd recommend getting a mac but for many other reasons besides your iphone. I'm very serious about that advice. I got tired of several weekends a year spent on fixing windows problems. That just hasn't happened since switching to Apple. I also think that every household should have at least one Mac if for no other reason then using it for internet and email to avoid the viruses.

    As for the 3gs to 4.0 on windows I can't help you on that. I would say that I'd try to keep the older baseband even if that meant sticking to 3.0 for now. The Dev team does state that the 04.26.08 is the preferred baseband so if you have it then keep it. If you knew someone with a Mac that would be best. The JB doesn't take much time at all to preform.
     
  16. cwrenn macrumors newbie

    Joined:
    Jul 4, 2010
    #16
    many thanks greg...

    i may try and use my sister in laws mac...or I may just wait for the Comex JB...:)
     
  17. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #17
    Again, that was before Ultrasn0w was updated to unlock all current basebands. During those days, it was Ultrasn0w for 4.26.xx or Blacksn0w for 5.11.xx. Ultrasn0w was the obvious choice, thus 4.26.xx

    Just isn't the case anymore.
     
  18. DarkCloud2015 macrumors member

    DarkCloud2015

    Joined:
    Feb 27, 2010
    #18
    Don't know about multi-tasking, but my 3G is slooooooooow with wallpapers, takes about 5 min to launch an app, and that's if it doesn't crash. Going to re-JB and disable wallpapers.
     
  19. ojimenez macrumors newbie

    Joined:
    Apr 5, 2011
    #19
    No MAC needed

    Fortunately, you don't have to either buy a mac or use your sister's mac. You can install on your PC VMware and a virtual machine of MAC OS and you will be able to use Pwnage.

    That's what I did and everything worked fine.

    Cheers.
     
  20. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #20
    Hey Dude.... did you know that you answer the thread that more than 6 months old? LOL :D
     
  21. abdull macrumors newbie

    Joined:
    Feb 20, 2012
    #21
    hello i have an unlocked i phone 3gs 32g and i need to restore it but itunes is asking me for an update as well, is it ok to update an unlocked i phone?
     

Share This Page