Can I Use 4.2.1 SHSH Blobs To Downgrade to 4.1

Discussion in 'iPhone' started by AppleTecFan, Jan 19, 2011.

  1. AppleTecFan macrumors 6502

    AppleTecFan

    Joined:
    Jul 7, 2009
    Location:
    N/A
    #1
    Can I Use SHSH Blobs From 4.2.1
    To Downgrade My iPhone 4 To 4.1

    So I Can Have an Untetherered Jailbreak
     
  2. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #2
    If successful, yes, but your baseband will be stuck at 4.2.1's version.
     
  3. AppleTecFan thread starter macrumors 6502

    AppleTecFan

    Joined:
    Jul 7, 2009
    Location:
    N/A
    #3
    Ya This iPhone Is Factory Unlocked So thats Not a Problem
    So Your %100 Sure Its Able?
     
  4. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #4
    you can't do it unless you have the blob for 4.1...
     
  5. AppleTecFan thread starter macrumors 6502

    AppleTecFan

    Joined:
    Jul 7, 2009
    Location:
    N/A
    #5
    Explain Why...
     
  6. dancedreamfly macrumors member

    Joined:
    Nov 3, 2010
    #6
    I think it's because when Apple releases new firmware updates, somewhere down the line, they stop signing the older updates. Remember, when restoring in iTunes, towards the end of the process, it shows "Verifying software update with Apple." If you try to restore to 4.1 without SHSH blobs, it'll fail because Apple no longer signs 4.1. If you run TinyUmbrella (assuming you have 4.1 blobs), iTunes is somewhat tricked into thinking that Apple has verified the software restore and your downgrade will be successful. The 4.2.1 blobs will only be useful once 4.3 comes out and you wish to downgrade to 4.2.1.

    This is only how I understand all the SHSH talk. For the more knowledgeable souls out there, please feel free to correct me.
     
  7. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #7
    If you have 4.2.1 blobs you can restore to firmware version? You guessed it 4.2.1
    If you had 4.1 blobs you could restore/downgrade to 4.1.
    You cannot restore to any firmware version but the latest one out or the version you have shsh blobs for.
     
  8. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #8
    The blobs that get saved are not based on the fw running on the iPhone, but the fw that apple is currently running on their servers when you start saving them, in your case the only one that was running was 4.2, so you can't go down to 4.1 anymore.
    You need your phone specific blob of X fw to be able to go down to X fw by using saurik's server and if you don't have the one you want then you can't go down to that fw.
     
  9. gngan macrumors 68000

    gngan

    Joined:
    Jan 1, 2009
    Location:
    MacWorld
    #9
    Search it yourself...
     
  10. techluvr macrumors regular

    Joined:
    Mar 22, 2010
    Location:
    OK, USA
    #10
    Short answer: No.

    Long answer: 4.2.1 blobs only work for 4.2.1, 4.1 blobs only work for 4.1, etc. You can't use one set of blobs for a different firmware version, and you can't use one device's blobs on another device.
     

Share This Page