Can login but not download from the App store using Mojave -SOLVED

Niek D

macrumors newbie
Original poster
Dec 28, 2008
6
1
I can't download software or updates anymore on my MacPro 5.1 with RX580 and running Mojave 10.14.6. I can login to my App store account and everything seems to work but when I click on a program or update I only get a spinnig circle. I deleted caches and preferences, tried different users and installed Mojave on a pristine second startup disk. Very basic, no iCloud account, different username, the newly installed system downloaded the security-update and Safari 13.04, I can login to my App store account but still can not download any software from the Appstore. Not the software I bought like FCPX, no free software or new software. A second (older) App store account also did not work, I can login but not download..

I'm out of ideas how to download any software at all from the Apps store with my Macpro 5.1 and Mojave.

I have a Macbook and a Macpro 3.1, both running El Capitan. They work as expected, when I login in my App Store account I can download or update all programs. The same on the Macbook from my girlfriend running Mojave, when I login on my App store Account. So it seems to be only a problem on my Macpro 5.1 running Mojave and it started sometimes this year..

Has anybody any idea what causes this problem?

Update: Made it a basic Macpro 5.1 with HD 5770 videocard and only mouse and keyboard: still no downloads.
Startup from an older High Sierra disk in 10.13.6 and everything works, even with the RX580, a Blackmagic Intensity card, an USB 3 card and a PCI-NVME card installed. So it really looks like a Mojave issue..

Update II: Installed a disk with High Sierra 10.13.6. Everything works. Update that disk from High Sierra to Mojave: same issue, login no problem, but still no downloads or updates from the App store. The iTunes store works, with the same account I can download books and music..

Update III: Well, why not, reset NVRAM.. And that solved the problem.
What changed a week ago, why it did not reset when I changed the battery on the motherboard, why my account worked perfectly with Mojave in the iTunes store and with High Sierra in the App store I still don't understand...
 
Last edited: