Can Not Update Airport Extreme & Express to Firmware 7.4.1

Discussion in 'Mac Accessories' started by GajieP, Mar 7, 2009.

  1. GajieP macrumors newbie

    Joined:
    Dec 4, 2008
    #1
    Hi everyone. I am having some difficulties updating both my previous generation Airport Extreme and Express from firmware 7.3.2 to the new 7.4.1. I updated the Airport Utility to version 5.4.1 via OS X software update, but whenever I check for updates in the Airport Utility I get the following message; "There was an error connecting to the update server. Check your network settings and try again". I have checked on Apple's support page and they claim that this should disappear after a few minutes. However, even after I leave Airport Utility open for a long time it still gives me the same message. Can anybody please help me in solving this problem? I would really appreciate it.
     
  2. djpaetkau macrumors newbie

    Joined:
    Jan 20, 2007
    #2
    I'm having the same problem. I've been trying it on and off for days, but I've yet to get it to work and connect, always giving me that same error. Surely there must be an alternative way to download and install the update??
     
  3. matthb macrumors newbie

    Joined:
    Jan 1, 2009
    #3
    Lucky you. DON'T INSTALL IT.
     
  4. WHM macrumors regular

    Joined:
    Feb 5, 2008
    Location:
    South
    #4
    Do Not..... I Repeat Do Not Install The New Software.. It Sucks
     
  5. dewser35 macrumors newbie

    Joined:
    Dec 16, 2008
    Location:
    Arlington, TX
    #5
    Why do you say that? I've been having some reliability issues as of late for my airport express used as airtunes. I was able to install it and I don't see anything up yet?:confused:
     
  6. jlpoore89 macrumors 6502

    Joined:
    Feb 16, 2009
    Location:
    Beaumont, Texas
    #6
    You must delete Airport Utility 5.4.1 (go to your Utilities folder and move it to your trash then empty your trash) and go to Apple's website and manually download Airport Utility 5.3.2 and install it. Heres the link for the Leopard version:

    http://www.apple.com/downloads/macosx/apple/application_updates/airportutility532forleopard.html

    And the Tiger version:

    http://www.apple.com/downloads/macosx/apple/application_updates/airportutility532tiger.html

    Once you have installed it you can then update your Airport Extreme/Express firmware to 7.4.1 through the utility. Once your base station has restarted verify that you can configure its settings. If you can then go to Software Update and redownload Airport Utility 5.4.1. It should work and you should be able to configure your AE.

    The problem is that the new Airport Utility doesn't recognize the old AE firmware. So you must install the new firmware BEFORE installing the new Airpot Utility.

    Just had the same problem today and Apple didn't even know how to fix it and they tried telling me that it was a problem with my AE, I ended up figuring it out on my own and then called Apple back and told them that it was a problem with their software.
     
  7. chandsa Guest

    Joined:
    Feb 1, 2009
    #7
    I have updated both the AU and AE to their latest and greatest versions respectively. However, the connection speeds have drastically dropped down for me. Its not my ISP because I am seeing this drop in speed only after updating the firmware for the AE. So I am wondering what the need is to update to the latest version and if there is any way I can go back to the earlier version of the AE firmware. Being a Mac newbie I just clicked on update every software when I got the notification. I should learn to refrain from doing that.

    Any tips/suggestions on how to go back to the earlier version of the AE firmware?

    Thank you!
     
  8. chandsa Guest

    Joined:
    Feb 1, 2009
    #8
    Whew! I answered my own question. After searching on Apple's website, I found this article about going back to an earlier version of the firmware and boy does this work like a charm! The blazing fast speeds are back and I'm a happy camper, though my curiosity is now perked up as to why the update would slow down my internet connection. Any thoughts?

    Thanks!
     

Share This Page