Cannot install MacOS Sierra: “internal error”

Discussion in 'macOS Sierra (10.12)' started by lexvo, Nov 16, 2016.

Tags:
  1. lexvo macrumors 65816

    Joined:
    Nov 11, 2009
    Location:
    The Netherlands
    #1
    Yesterday I tried to upgrade my fathers 2012 iMac from El Capitan to Sierra. Unfortunately after 30 minutes the process stopped with an “internal error”.

    I searched the internet what to do about this. I got a lot of tips like reset PRAM/NVRAM, boot in safe mode etc..

    The safe mode didn’t work however. Every time I held shift when rebooting, some characters appeared on the screen and the iMac booted again immediately.

    I did a PRAM/NVRAM reset, but had some doubts: what if we waited again 30 minutes and that “internal error” popped up again? It would be more trial and error this way.

    At the end I found that we wasted too much time. I rebooted the iMac in Recovery mode (which worked thankfully) and restored from a Time Machine backup.

    I had already read about some people having problems installing the first release of Sierra but had hoped that this would be solved now.

    My question is: what can I do and/or what tips do you have so I have the biggest chance of successful upgrading to Sierra? I want to make sure we won’t spend time with trial and error and waiting 30 minutes every try. Thanks in advance.
     
  2. airlied macrumors regular

    airlied

    Joined:
    Jul 8, 2011
    #2
    Can you clarify the installation progress? Did you download sierra from app store then install it right away? There is a slight chance that if you install the files right away the "pre-installation process" (which is the "copying files to location" before the first reboot) goes wrong, some files cannot be written correctly so you will get the error. the best way to install sierra (or any version of osx) without erasing the disk is to reboot to recovery mode then download directly from server. or the second best way is to install a "temp os" on external usb disk, then boot from that os and download the file from app store then install it.
     
  3. lexvo thread starter macrumors 65816

    Joined:
    Nov 11, 2009
    Location:
    The Netherlands
    #3
    Thank you. I installed it right away. I will try your suggestion using recovery mode and download directly from the server.
     

Share This Page