Cannot setup Google Apps Email

Discussion in 'iPhone' started by That-Guy, Feb 28, 2012.

  1. That-Guy macrumors 6502a

    That-Guy

    Joined:
    Feb 25, 2012
    Location:
    UK
    #1
    Back Again,

    I am trying to setup my Google Apps Email Address using these settings:
    http://support.google.com/mobile/bin/answer.py?hl=en&answer=138740

    But I am getting the error "Cannot Get Mail - The connection to the server failed."

    I have already enabled Google Sync in my Google Apps Account and am using the following settings:

    Email: (My Email Address)
    Server: m.google.com
    Domain: (blank)
    Username: (My Email Address)
    Password: (My Email Password)
    Use SSL: ON

    Also I have setup my normal email address using the method above and it works fine.

    What am I missing?

    Thanks in Advance :)
     
  2. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #2
    Google apps domains need to be explicitly set up by the domain administrator to support Google sync.

    http://support.google.com/a/bin/answer.py?hl=en&answer=148484

    Also: the domain must be on a Google Business or Education account. The freebie domain accounts can't be configured for Sync, and you'll have to set your mail as an IMAP account instead.
     
  3. kicko macrumors 65816

    Joined:
    Aug 26, 2008
    #3
    when you say "google apps email" you mean from within the google search app? or are you trying the default app mail app? or the offical gmail app?
     
  4. That-Guy thread starter macrumors 6502a

    That-Guy

    Joined:
    Feb 25, 2012
    Location:
    UK
    #4
    Ah crap didn't realise you had to pay, that sucks.

    So I guess the best way would be to add it as a normal Gmail Account and get it to Sync avery 30 mins or something?
     
  5. Meanee macrumors 6502a

    Joined:
    Mar 8, 2011
    #5
    Google wants you to pay if you use Outlook. For Mobile, you should be able to use Exchange setup method. But you do need to enable it.
     
  6. takeshi74 macrumors 601

    Joined:
    Feb 9, 2011
    #6
  7. TLewis macrumors 65816

    Joined:
    Sep 19, 2007
    Location:
    left coast, US
    #7
    Did google change their terms again? I have a freebie apps account that's maybe 14 months old, and google sync works fine with it. I'm using a domain that's hosted elsewhere, though (just the MX records point to google).
     
  8. That-Guy thread starter macrumors 6502a

    That-Guy

    Joined:
    Feb 25, 2012
    Location:
    UK
    #8
    Can you just confirm what settings you are using for the account?
     
  9. TLewis macrumors 65816

    Joined:
    Sep 19, 2007
    Location:
    left coast, US
    #9
    I'm using the same settings you are.

    However, did you enable google sync via the administrator control panel, as scaredpoet said? Under Settings->Mobile, you need to enable google sync.

    Edit: OK, scaredpoet's google link is a bit confusing. Go here to find your admin control panel: https://support.google.com/a/bin/answer.py?hl=en&answer=182076
     
  10. Menel macrumors 603

    Menel

    Joined:
    Aug 4, 2011
    Location:
    ATL
    #10
    This.

    Google Sync, Exchange mode, works fine with Free Google Apps accounts, and even free GMail.com accounts. You need to enable sync in settings.

    If you have enabled two-way authentication, as you should!, you will need to generate an app specific password for mail on your iPhone.

    ----------

    Another useful link
    http://support.google.com/a/bin/answer.py?hl=en&answer=135937

    Also once setup, browse to this link with your mobile device, bookmark it, for additional settings. Mail control bevhaior, and Cal options:
    http://m.google.com/sync

    Also bookmark the app specific passwords link:
    https://accounts.google.com/IssuedAuthSubTokens
     
  11. ugahairydawgs macrumors 68020

    ugahairydawgs

    Joined:
    Jun 10, 2010
    #11
    You just need to login to the Google Apps dashboard, click on Settings > Mobile, and check the box that says to enable Google Sync.
     
  12. That-Guy thread starter macrumors 6502a

    That-Guy

    Joined:
    Feb 25, 2012
    Location:
    UK
    #12
    Thats already enabled :(

    Can I just confirm you leave the Domain field blank, the user name should be my domains email (myname@mydomain.co.uk) and the password is just the email password?
     
  13. ugahairydawgs macrumors 68020

    ugahairydawgs

    Joined:
    Jun 10, 2010
    #13
    That's right.

    E-mail and user name should be your e-mail address, server should be m.google.com, and then the password. That should be all you have to enter.

    If that doesn't do it I would disable sync and give it a half hour or so and try to re-enable and add the account to your phone then.
     
  14. TLewis macrumors 65816

    Joined:
    Sep 19, 2007
    Location:
    left coast, US
    #14
    That's what I have. However, as Menel says, if you use two-factor auth (and you haven't said), you have to create and use an app-specific password. You can't use your normal gmail password.
     
  15. That-Guy thread starter macrumors 6502a

    That-Guy

    Joined:
    Feb 25, 2012
    Location:
    UK
    #15
    No not using two-factor auth.
     
  16. rocknblogger macrumors 68020

    rocknblogger

    Joined:
    Apr 2, 2011
    Location:
    New Jersey
    #16
    That's not true. I have multiple free Google Apps accounts set up using Sync via Exchange.

    I'll mull it around as to why it may not be working and take a look at my account settings. If I come up with something I'll be back.
     
  17. That-Guy thread starter macrumors 6502a

    That-Guy

    Joined:
    Feb 25, 2012
    Location:
    UK
    #17
    Thanks that would be great :)
     
  18. TLewis macrumors 65816

    Joined:
    Sep 19, 2007
    Location:
    left coast, US
    #18
    It just occurred to me that this is probably your real problem. Either google is blocking connections from where you are (possible, but perhaps unlikely), or whatever cellular/wifi service you're using is blocking you from accessing google's servers. (What are you using, cellular or wifi, and what service? Orange? Work wifi?) I don't think this will help but, instead of "m.google.com", you could try using "74.125.127.193" (without the quotes). This will help if someone's screwing with the nameservers, but that's probably unlikely. (Even if this works, it's not guaranteed to continue working.)
     
  19. That-Guy thread starter macrumors 6502a

    That-Guy

    Joined:
    Feb 25, 2012
    Location:
    UK
    #19
    Thanks tried using the IP Address instead but sadly no difference.

    Have tried on Mobile Data on giffgaff (O2 UK) and also on Wifi in two locations.

    I really don't understand why its not working :(
     
  20. rocknblogger macrumors 68020

    rocknblogger

    Joined:
    Apr 2, 2011
    Location:
    New Jersey
    #20
    I take it still no success?

    Is this your Google Apps account? In other words are you the administrator and owner of the domain name?
     
  21. That-Guy thread starter macrumors 6502a

    That-Guy

    Joined:
    Feb 25, 2012
    Location:
    UK
    #21
    All sorted now, it turns out it was a Network Profile (the networks settings file that gets sent to your phone when you put the sim in) although these settings were correct I have to remove this profile and enter the Data/MMS Settings Manually.

    Don't know why this would fix it as the settings I entered were the same as the ones in the profile but I found a few people who had the same problem.

    Thanks everyone for the ideas :)
     
  22. rocknblogger macrumors 68020

    rocknblogger

    Joined:
    Apr 2, 2011
    Location:
    New Jersey
  23. gw0gvq Contributor

    gw0gvq

    Joined:
    Jan 30, 2012
    Location:
    Barry, South Wales, UK
    #23
    macbook pro mail

    the mail in my macbook pro wont accept google app email i have . Ie its an educational it will download from my ordinary gmail I use regular but when its set to my mac email it wont retrieve anything.
     

Share This Page