MP 1,1-5,1 Cannot sign in to iMessage on Mac Pro 4,1→5,1

Discussion in 'Mac Pro' started by DanSilov, Aug 12, 2019.

  1. DanSilov, Aug 12, 2019
    Last edited: Aug 13, 2019 at 11:36 PM

    DanSilov macrumors member

    Joined:
    Sep 19, 2016
    #1
    [SOLVED → Reset NVRAM 3 times in a row]

    It might sound like a message for another forum, but hear me out. I have a problem on my 4,1→5,1 Mac Pro, where I get an "Activation Error" whenever I try to sign in to Messages. And it was working fine before, just stopped at some point (unfortunately I don't recall what preceded it).

    Now, I've researched the problem, and tried all possible solutions. Here are a couple of links summarizing most known solutions:
    http://tips.stevenchu.com/tech/mac-osx/solution-imessage-messages-on-mac-stopped-working-completely/
    https://appletoolbox.com/error-occurred-during-activation-for-imessage-or-facetime-on-mac/

    After I've tried everything, it came to this: most probably my Mac's serial number is blocked somewhere on iMessage servers due to too many incorrect logins or whatever. The only solution is to call Apple, and ask them to check for the block and remove it. And I've tried to do just that.

    I've called Apple Support and spend around an hour one the phone with them. When we got to the serial number check, I've realized it might not be as easy:
    • My serial number belongs to 4,1, but I'm running Mojave, which is not supported on 4,1.
    • I'm also spoofing the serial number to enable HEVC (as per this post) with the following line
      'sudo nvram boot-args="shikigva=96 shiki-id=Mac-7BA5B2D9E42DDD94"', although it probably doesn't affect the real serial number, but I can't be sure.
    Apple support told me that they've tried to remove the block, but it didn't work out, because after another check it doesn't seem that I have a block on my Mac. After that they've told me the following: "Looks like it's not AppleID/iCloud issues, because it works on other Macs, so it's hardware issue. And because your computer is now obsolete, we cannot provide support for it. Goodbye."

    Question, did anyone here had a similar issue with Mac Pro? Is there any point trying to contact Apple again, but disabling all the spoofing beforehand? Maybe any other advice someone might give me?
     
  2. mattspace macrumors 65816

    mattspace

    Joined:
    Jun 5, 2013
    Location:
    Australia
  3. DanSilov thread starter macrumors member

    Joined:
    Sep 19, 2016
    #3
    Sure. Multiple times. Basically, tried every advice I could find: reseting PRAM, checking and unchecking timezone detection, unsigning from iCloud, deleting IDS keys from the Keychain, deleting Messages preferences from ~/Library. Nothing worked, and it all comes down to a block on Apple's side, but my only concern if they will actually process requests from 4,1→5,1 owner.
     
  4. Alex Sanders74 macrumors 6502

    Alex Sanders74

    Joined:
    Nov 26, 2013
    Location:
    Toronto, Canada
    #4
    Sounds like the boot ROM needs rebuilding... this issue is generally fixed by doing so. You'll need to ask for help on that one. There is a member here that may be able to help you, unless he is swamped with other projects.
     
  5. DanSilov thread starter macrumors member

    Joined:
    Sep 19, 2016
    #5
    Can you point me in the right direction? Or I hope he notices this thread to give advice.
     
  6. Alex Sanders74 macrumors 6502

    Alex Sanders74

    Joined:
    Nov 26, 2013
    Location:
    Toronto, Canada
    #6
    Likely he'll reply. I know he's an exceptionally busy guy and was getting inundated with requests for a while. It's likely he'll see the post and offer some suggestions, but I don't want to add to his frustrations....
     
  7. DanSilov thread starter macrumors member

    Joined:
    Sep 19, 2016
    #7
    Thank you, I probably know who you are talking about, don't want to bother him just yet, hopefully he'll reply. But in theory it does sound like the right area to investigate.
     
  8. tsialex macrumors 603

    tsialex

    Joined:
    Jun 13, 2016
    Location:
    Brazil
    #8
    I posted this before, I just made some edits.

    It's not a problem of MP4,1 serial and Mojave, this happens with ElCapitan too. This is happening for some time with a lot of Mac Pro 2009 owners, the causes are diverse, but always end with the fact that the MP4,1>5,1 don't have enough hardwareIDs to identify correctly as a real Mac.

    Since I bricked my 2009 Mac Pro and repaired it but couldn't get iMessage to work again, I've I started to investigate this problem and found that:
    • A lot of Mac Pros have a corrupted NVRAM and sometimes the 3 sequential clear NVRAM process can remove enough of the problem to make iMessage work again.
    • Some Mac Pros are clones, this happens with everyone using a MATT card or with someone that had the backplane replaced and the old one is repaired but the SPI flash is not fully cleaned/not given new serial and put back on the market again, this is improbable but happens, and when Apple iMessage validation servers identifies this, the Mac Pro is blacklisted for iMessage.
    • Apple technicians, or 3rd party, sometimes forget to correctly serialise the backplane when it's replaced, this happens more commonly with in-house replacements like universities or corporations that have in-house technicians that replace the backplane themselves.
    • Some early MP4,1, or later ones refurbed, never had all the needed hardwareIDs (override_version Base_xx, hardware descriptor, SSN, HWC, SON, Gaid, LBSN, BD) from factory or from a repair/refurb.
    • MP4,1>5,1 firmware upgrade process overwrite the BootROM with a MP5,1 BootBlock that don't correspond with the rest of the BootROM, this is a secondary problem but if your Mac Pro is blacklisted you have to have everything correct or you won't get it working again.
    Anyway, you probably have one or more of what I explained above and this can be solved with a careful BootROM reconstruction, but clear your NVRAM 3-times sequentially before anything.
     
  9. DanSilov thread starter macrumors member

    Joined:
    Sep 19, 2016
    #9
    Damn, my bad, I usually search the forum before posting, but this time I thought the issue is too specific and rare. I guess I was wrong )

    Anyway, single NVRAM reset didn't work, as I tried it before, but resetting it 3 times did the trick! Thank you!

    I was wondering, does this mean that my NVRAM is somewhat permanently corrupted due to age, and this or other potential issues can arise in the future?
     

Share This Page

8 August 12, 2019