Cannot transfer large files between drives - data can’t be read or written

Discussion in 'OS X Yosemite (10.10)' started by hardanger, Mar 6, 2015.

  1. hardanger, Mar 6, 2015
    Last edited: Mar 6, 2015

    hardanger macrumors newbie

    Joined:
    Mar 6, 2015
    #1
    Hi!


    I am trying to transfer a couple of large files to a hard drive from my internal ssd. Both are set to Mac OS Extended (Journaled). Small files transfer fine, but large ones (eg. 20GB) get a varying distance through and then the following error message comes up:

    The Finder can't complete the operation because some data in “FILENAME” can’t be read or written. (Error code -36)

    I have tried to ensure read&write permissions are allowed, but this hasn't helped. This has occurred with multiple files.


    Any help would be very much appreciated.


    Mac mini, OS X Yosemite (10.10)
     
  2. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #2
    If CMD-I on the source and dest hard drive is "Ignore Ownership" enabled on any of them?
     
  3. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #3
    [[ The Finder can't complete the operation because some data in “FILENAME” can’t be read or written. (Error code -36) ]]

    Possible data corruption within the file (causing the finder to abort the copy)?

    Possible bad sector(s) on source drive? (causing incomplete read of file, thus finder aborts copy).

    What happens if (before copying) you select one of the large files by right-clicking on it, and then choose "compress" from the contextual menu?
     
  4. hardanger thread starter macrumors newbie

    Joined:
    Mar 6, 2015
    #4
    Thanks for the replies guys. I have finally got it copied - very strange. It took close to 20 attempts over multiple days and sessions, and finally it got through the whole 50-odd gb without an error!
     
  5. NoBoMac macrumors 6502a

    Joined:
    Jul 1, 2014
    #5
    I've had an occasional error with big folder copies. Usually Library and or Music folder. Seems to be the error occurs when the contents are getting updated or locked by some app (changes, updating; iTunes which is usually open and doing things). When copying those, I'll redo each folder individually.

    I'll usually try to copy only a folder or two on the big ones. Music is big since latest iOS vetsions store app updates there. Library, system stuff. Others, I try to not have apps up that will lock that (eg. iPhoto).
     
  6. hardanger thread starter macrumors newbie

    Joined:
    Mar 6, 2015
    #6
    Fix to issue!

    Fishrrman gave me a great footing for a nice solution to the issue. Although compressing the file (via the right click menu) doesn't help (the error message on transfer doesn't help). I have found a 100% (so far), reliable fix:

    1 - Open Archive Utility
    2 - Open preferences
    3 - Change the 'Save archive' option from 'into same directory as being archived' to where you want the file after moving it
    4 - Close preferences, and go File->Create archive with the pesky file you want to move
    5 - Let it run through, expand the file when done if you want, and then just change your preferences back to default

    It's a bit long-winded, but it has worked every time I have tried.
     

Share This Page