Cannot Upgrade Safari - "Need 10.5.2 or newer?" Um, I have 10.5.4?

Discussion in 'Mac Apps and Mac App Store' started by Khryz, Aug 10, 2008.

  1. Khryz macrumors 6502a

    Joined:
    Jan 7, 2007
    #1
    At one point in time Safari was behaving. Then about a month ago it was being very stupid and not loading so I deleted Safari in the hopes of re-downloading it from Apple.com. I later figured out you can't - so I got the Leopard install disks and re-installed Safari 3.0.4.

    Now I want to update Safari to the newest version which is available on the Apple Website. I follow the steps, only to come to the Installer package which says when I'm choosing a place to store the update, that it cannot install Safari because I need Mac OSX 10.5.2 or newer.

    Now obviously this is a bug or something because I have 10.5.4.

    Can someone tell me what's going on?
     
  2. m1ss1ontomars macrumors 6502

    Joined:
    Oct 1, 2006
    #2
    It probably either means you need 10.5.2 exactly (that's what the download page implies) or there is a bug in the OS version detection script (less likely). If you're sure you need this update (you may not), you can use Pacifist to install it.
     
  3. SnowLeopard2008 macrumors 604

    SnowLeopard2008

    Joined:
    Jul 4, 2008
    Location:
    Silicon Valley
    #3
    Download the Safari 4 Developer Preview! :D That works on all versions of Leopard. 10.5.x
     
  4. neski macrumors member

    Joined:
    Aug 24, 2007
    #5
    oh man thats bad i have the same problem and i cant seem to fix it. i get the same error as you.
     
  5. Khryz thread starter macrumors 6502a

    Joined:
    Jan 7, 2007
    #6
    I had that but Safari 4 disables Mail Notes so I uninstalled it.

    What's the point of an upgrade if you need an older Mac OSX update? That doesn't make any sense. And what is Pacifist?

    Care you elaborate on what I'm supposed to do with this? I'm a Mac N00b.
     
  6. m1ss1ontomars macrumors 6502

    Joined:
    Oct 1, 2006
    #7
    Yeah, Safari 4 breaks random little things.

    It's an upgrade only if you have an earlier version of Mac OS X. If you have the current version of Mac OS X, you should never need it. Duh.

    As for Pacifist, seriously, just Google it. Or search the forums for hundreds of posts asking the same question.

    WebKit is just like Safari, but it doesn't use Mac OS X's built-in WebKit.framework; it uses the latest version, compiled nightly.
     

Share This Page