Cannot Verify Update & Can't Get Into Recovery

Discussion in 'macOS Mojave (10.14)' started by gadgetfreak98, Aug 3, 2019.

  1. gadgetfreak98 macrumors regular

    Joined:
    Feb 6, 2009
    #1
    I have a 2018 Mac Mini. I foolishly decided to create a new APFS volume on my startup drive to test out Catalina. I thought I would be safe with APFS volumes, since I wasn't updating my actual Mojave startup volume. Furthermore, I have two additional clones of my Mojave startup drive and a Time Machine backup on my Synology. So I thought I was safe to mess around with a clean install of Catalina.

    Anyway, what I didn't realize was that it was going to replace my internal SSD's recovery partition with the Catalina version -- even thought I ended up deleting the Catalina APFS volume. And by the time I realized that was the case, it seemed Carbon Copy Cloner has also cloned over the Catalina beta recovery partition.

    While my Mojave startup volume is generally operating ok, I simply cannot update to 10.14.6. The problems are:

    • I always get the Cannot Verify error if I try to do a normal update from system utilities
    • I cannot start from the recovery volume to do the update, because it tries to install Catalina instead
    • I have tried to use a install macOS thumb drive with Mojave... no luck, and cannot verify
    • Internet Recovery either ends in a -9000f error or just never actually loads
    • I have wiped the startup drive completely to try to do a fresh install from Internet Recovery or otherwise, and that fails too
    • I CAN clone back to my startup drive to have a working copy of 10.14.5, but have no ability to update
    After hours, both on my own and with senior level technicians at Apple, I'm just stuck.

    Any ideas? It feels like I need to get into the regular recovery partition, but either I cannot do that when the drive is clean, or it otherwise goes to the Catalina installer. Very frustrating! And a key lesson learned that APFS volumes for beta system software -- while seemingly safe and elegant -- will mess with other things!

    Thanks for any advice!
     
  2. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    You have learned an important (and BITTER) lesson:

    Never never never never never never never never never never never never never never never never never never never never (had enough yet?)...

    ... NEVER install a copy of an experimental and yet-unreleased version of the Mac OS on your primary boot drive.

    Always always always always (that's enough!) use an EXTERNAL drive for your "experimentations".

    "I cannot start from the recovery volume to do the update, because it tries to install Catalina instead"

    If you are seeing the Catalina installer, can't you just "quit it" to see the rest of the OS utilities in the recovery partition?

    If you can, I suggest that the first thing you do is open Startup Security and DISABLE all the t2 protections.

    Also, open terminal and DISABLE "SIP" with the following command:
    csrutil disable

    Can you get this far?
     
  3. Honza1 macrumors 6502

    Joined:
    Nov 30, 2013
    Location:
    US
    #3
    If you have different (external) installation of MacOS (10.14.x version), can you select it System preferences and reboot on that? If that can be done, one would assume you can simply completely wipe the whole SSD device - erase the boot drive in the Mini - wiping all partitions and then install on it (still running off the external drive) the 10.14.6 version. This should recreate the whole structure for 10.14.6 as it is starting with "empty SSD". And then clone back your 10.14.x partition.

    Now, I am bit worried if this will work - my MBP has developed some weird SSD/APFS error. I did exactly what described above, but I was unable to do complete Erase of the SSD device. The procedure actually crashed the MBP mid way of reformatting. I took it to Apple store and the Guru there expected this procedure to work also, tested the same steps - and then sent the MBP for repairs. It came back with new mainboard with SSD, since the SSD is soldered in. And system was preinstalled, of course. So while I Apple's web site and Gurus assume one should be able to Erase the SSD device completely, I cannot guarantee it will work. But if this Mini is under warranty, the only risk is it will take few days for Apple to replace mainboard. Annoying, but also a solution...
     
  4. gadgetfreak98 thread starter macrumors regular

    Joined:
    Feb 6, 2009
    #4

    Thanks. I actually had done this step... via Internet Recovery, I wiped the drive completely. Then I couldn't install Mojave, so I cloned over from another drive. And 10.15 beta came back over on the recovery.
     
  5. gadgetfreak98 thread starter macrumors regular

    Joined:
    Feb 6, 2009
    #5
    Alright so I’m finally in front of my computer again. Here’s the update:

    I restated in Internet Recovery and tried to go into Startup Security to disable T2 security. But when I went into the utility it said I had no security token.

    So then I found this post and followed the Terminal suggestions to create a token for my user account. https://discussions.apple.com/thread/8509743?answerId=33977796022#33977796022

    After that I tried to install the 10.14.6 update directly while in my startup volume ... just in case that was the issue. It was not and I still got the can’t verify issue.

    So I went back to Internet Recovery and I decided not to go all the way on T2 security but just went to Medium.

    Upon restarting back into my startup drive I was finally able to install 10.14.6 through the System Utilities update function — or at least I believe I am doing so (still 15 min on the update) but looks as anticipated. No need to disable SIP btw.

    So thank you for the advice! That T2 chip is quite aggressive! And lesson learned on not touching my startup drive.
     

Share This Page

4 August 3, 2019