Can't access Recovery after 5,1 upgraded to 10.14.5

Discussion in 'Mac Pro' started by flaubert, May 21, 2019.

  1. flaubert macrumors regular

    flaubert

    Joined:
    Jun 16, 2015
    Location:
    Portland, Oregon
    #1
    So, this is weird... my 2010 cMP 5,1 was running fine on 10.14.4 and firmware 140.0.0.0.0 until last night. Last night I finally undertook the firmware update process to 144.0.0.0.0 and the install of the full 10.14.5, no problems. At the conclusion of it all, I booted my Mac up normally and confirmed that it is indeed running latest Mojave 10.14.5, and the firmware is upgraded to the 144 version. Then, since I planned to disable hyperthreading via the Apple supplied method, I tried to boot into Recovery partition. No go! I held the Command-R keys down from start-up through several minutes, and seemingly got no where. Eventually I just held the power button until it powered off. I repeated the attempt several times, varying when I initiated the keypress (at instant of power button pressed, just before tone, middle of tone), and how long I held it (a few seconds beyond tone, until the backlight of the screen came on at about the two minute mark, then several minutes beyond that). I think the longest I let the whole thing go in an attempt was ten minutes, though the longest I held down keys was around four minutes.

    Some random facts about the situation:
    - There is only one bootable disk in the system, the Mojave disk (SSD), and it is in a SATA slot, not on a PCIe card. There is a second disk in the system formatted as ZFS, but it should be a non-participant as far as the Recovery partition.
    - The computer has a Metal-capable RX 560 GPU.
    - On one of the later attempts I reset the PRAM, but not all attempts were with the PRAM reset.
    - On one of the later attempts I let it boot to full desktop normally, and then went in and manually selected the Mojave boot disk, just so that there wasn't any confusion about where to find the Recovery partition.
    - As I mentioned above, after about 2 minutes the backlight came on for the Apple Cinema display connected to the DisplayPort output of the RX560; the display remained black, however, and didn't give a block cursor in the upper left corner as it sometimes does during power-up and power-down. The second Apple cinema display is connected via DVI, and seemingly had no interaction at all.
    - My Mojave boot disk is formatted APFS, of course.
    - I know that I had a working Recovery partition under 10.14.4, since I booted into it without incident or holding down keys for insane lengths of time last week.
    - The keyboard is wired Apple USB, the mouse is wireless Apple trackpad gen 1.

    @bsbeamer mentions that one has to hold down the keys for a minimum of 3 minutes in this posting:

    https://forums.macrumors.com/threads/mp5-1-mds-mitigation-real-world-impacts-results.2182124/

    That was news to me; I know that I held it down for more than three minutes on one of the attempts, but it probably wasn't before the PRAM reset.

    I'm wondering: should I pull the RX560 out temporarily, and put in the HD 5770 to access the Recovery partition? Do my dirty work of disabling hyperthreading, shut down, and then switch back to the RX 560?
     
  2. crjackson2134 macrumors 601

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #2
    This is just a guess mind you but I have a feeling it's related to your GPU/Monitor setup.

    I would reduce the monitor connections to only one monitor and see what happens. If it's the same then try an alternate GPU. I'm not 100% sure you can get into recovery with a 5770. I believe you can, but I haven't personally tried it with 10.14.5

    Hang on, someone with a lot of trouble shooting skills will pop in here shortly and give you better advice. (I still think it's a good bet that it's GPU related).
     
  3. bookemdano macrumors 65816

    Joined:
    Jul 29, 2011
    #3
    This is good advice. Multiple monitors has been the culprit for a lot of boot issues in past experience. So yeah, try just one monitor via DP (and try both DP ports).

    Also, you could try this method via terminal to ensure that the cMP isn't for some reason ignoring your Command-R:

    Code:
    sudo nvram "recovery-boot-mode=unused"
    sudo reboot
    
     
  4. flaubert thread starter macrumors regular

    flaubert

    Joined:
    Jun 16, 2015
    Location:
    Portland, Oregon
  5. bsbeamer macrumors 68020

    Joined:
    Sep 19, 2012
    #5
    Without boot screens (non EFI GPUs) and the variety of setups (including "slower initial booting" NVME and other PCIe) getting to the recovery SCREEN can take awhile. You're not JUST getting to boot recovery, but waiting for graphics drivers to load. Many users will see what could best be described as a graphic glitch (green and pink in a square quadrant) before the driver actually loads. It is probably safe to release at that point since recovery boot has already been initiated.

    There is NOTHING BAD that can happen from holding longer, but there is a large chance users are releasing too soon which would/could cause machines to fail to boot to recovery properly.
     
  6. flaubert, May 27, 2019
    Last edited: May 28, 2019

    flaubert thread starter macrumors regular

    flaubert

    Joined:
    Jun 16, 2015
    Location:
    Portland, Oregon
    #6
    I finally got into recovery mode: I think unplugging the second DVI Apple Cinema Display from the computer is what did the trick. With only one display the recovery options screen was visible after almost exactly two minutes of holding down command-R.

    Edit: the basis for my belief that it was removing the second monitor that fixed it is this: with the two monitors the backlight of the mini display port connected monitor came on at just before two minutes elapsed (although the screen remained black), while with one monitor the monitor lit up with a progress bar at just before two minutes.
     

Share This Page

5 May 21, 2019