Can't connect to Brother HL-5140 printer on WinXP SP2 machine from 10.4.1

Discussion in 'macOS' started by feakbeak, Jun 21, 2005.

  1. feakbeak macrumors 6502a


    Oct 16, 2003
    Okay, I've given this a good three or four attempts over the past several weeks. After a couple hours I usually get frustrated and give up and come back to it in another couple weeks. I'm finally crying out for help. I've searched the net and found other people have had this problem as well. There were some suggestions for them but nothing that worked for them or me. Most if not all of those users also had Brother printers.

    Problem Summary
    I want to connect and print to my Brother HL-5140 printer that is physically connected to my WinXP SP2 computer via USB cable. The printer is shared on my PC and the account I am trying to connect with has full permissions to access, print from and configure the printer. I have all of the Windows File/Print sharing services enabled. I am not running any software firewalls (I just use my router's hardware firewall). I was printing from my Mac Mini just fine before upgrading to Tiger. With 10.3.8 and 10.3.9 I was able to connect and print without any issues using the exact same steps listed below.

    What I'm doing...
    1. Open System Preferences
    2. Click Print & Fax
    3. The Printing tab/section is highlighted - click the + to add a printer.
    4. Default Browser is selected - click More Printers....
    5. In the pop-up window select Windows Printing and my workgroup named Workgroup is selected. My Mac Mini (named Darwin) and my PC (named Einstein) show up in the list.
    6. I click on Einstein and it prompts me for credentials to connect. I enter my username and password and click OK. There is a long pause...

    What I get...
    I've also attempted to connect to the printer using the Advanced option and entering the Device Name and Device URI with the SMB path to the printer using the IP address. That shows up as a printer and would seem to work but no print jobs go through.

    Any ideas? I'm at a loss. I am hoping that 10.4.2 will miraculous solve my problem.
  2. MisterMe macrumors G4


    Jul 17, 2002
    I recall your asking about this printer before, but with MacOS X 10.3. At any rate, you know that you have to download and install Brother's CUPS driver for this printer on MacOS X 10.4. Brother tells you how to set up the printer for a direct USB connection and for an IP-connection. Hopefully, the steps for required for SMB can be substituted for those required for IP. Something else that you may want to try is to use your Windows computer as a TCP/IP print server. Then you can setup your printer as an IP printer.
  3. feakbeak thread starter macrumors 6502a


    Oct 16, 2003
    Thanks for your help, MisterMe.

    Here I tried to be all thorough and forgot to mention that I had already installed the Brother CUPS driver. Same problem, I'll have to take a closer look at the instructions Brother provides... but not tonight, I'm drinking with the gf tonight and I'll be heading out to IL for a long weekend tomorrow. I'll give it another try early next week. Hopefully 10.4.2 will be out by then. I'm doing the same thing as I did under 10.3 and no luck.

    I had forgotten I had posted on here about my printer under 10.3. You have a better memory than I do about my posts. I'm pathetic. :)

Share This Page