Can't delete folders on NAS - OS says in use but isn't

Discussion in 'macOS Mojave (10.14)' started by propower, Dec 9, 2018.

  1. propower macrumors 6502a

    Joined:
    Jul 23, 2010
    #1
    I am trying to clean up a NAS drive and when I go to delete a folder it says it can't because a file is in use. If I go into the folder and delete all the files that works. There are TONS of files in lots of folders.

    What is the way out??? I haven't opened this NAS drive in months!
     
  2. iRaynor SK macrumors 6502

    iRaynor SK

    Joined:
    Nov 15, 2014
    Location:
    Banská Bystrica, Slovak Republic
    #2
    I had the same problem with WD My Cloud. Solution was to use another device (in my case iPad) to delete it.
     
  3. propower, Dec 9, 2018
    Last edited: Dec 9, 2018

    propower thread starter macrumors 6502a

    Joined:
    Jul 23, 2010
    #3
    Tried it from another Mac computer on the network - no go yet :-(

    Tried it from a Windows machine - YAY - it worked!

    So what is the deal?? Mac OSX Mojave Beta 10.14.2 (18C52a) can't delete these but Windows can... Is there really no way??
     
  4. lexvo macrumors 65816

    Joined:
    Nov 11, 2009
    Location:
    The Netherlands
    #4
    Have you tried disconnecting/logging off and reconnecting? I had directories on my NAS I was not able to open. Reconnecting solved this.
     
  5. Howard2k macrumors 68020

    Howard2k

    Joined:
    Mar 10, 2016
    #5

    Could it be an SMB version issue?
     

Share This Page

4 December 9, 2018