Can't eject CD on MDD G4

Discussion in 'Macintosh Computers' started by zer0army, Feb 4, 2003.

  1. zer0army macrumors regular

    Jan 28, 2003
    My friend who has a Dual 867 called me up with a little problem. He put a CD-R into his CD-RW drive (he doesn't have a superdrive) but it couldn't be read. He attempted to eject the CD but it wouldn't come out. He said he tried everything but it wouldn't eject. He called Applecare and talked to them for 30 mins but they were unable to come up with a solution. They told him he would have to bring it into the nearest service center to be fixed. The nearest place is an hour drive and he would like to avoid having to go all that way.

    Has anyone had experience with this kind of problem ? or know how to fix it.

    If he opens up the side of the tower and pops the drive out is there a manual eject ?
  2. scem0 macrumors 604


    Jul 16, 2002
    back in NYC!
    I would be suprised if there was not a manual eject, but I have no
    idea. You know there is a Help/Questions part of the forums, right?
  3. e-coli macrumors 68000


    Jul 27, 2002
    There's several things you can try: ;)

    Attached Files:

  4. zer0army thread starter macrumors regular

    Jan 28, 2003
    Yes I'm realizing that now and will make a note for the future. I guess I just saw Hardware discussion first and quickly posted.

    e-coli: He tried that but apparently the Fans just cranked themselves up full blast and wined and screamed back at him.:D

    Anyone else have any suggestions ?
  5. ibookin' macrumors 65816


    Jul 7, 2002
    Los Angeles, CA
    Did he try restarting the mac and holding the mouse button down? This forces the drive to eject.

    If he did (or that didn't work) he should pry open the door in front of the drive and look for a small hole that a paper clip would fit in on the drive face. If there is one (I don't have an MDD to look at), then stick a paper clip in there and the drive door should pop open.

    If this doesn't work a trip to the service center is in order...

    [edit]: This "friend" wouldn't happen to be you, would it? :eek: Just kidding. :p
  6. LethalWolfe macrumors G3


    Jan 11, 2002
    Los Angeles
    Have him open the "door" on the front of his case covering the drive and he should see if there is a small pin hole on the front of the CDRW drive. Slide a paper clip into the pin hole and that should open the drive.

  7. Bear macrumors G3

    Jul 23, 2002
    Sol III - Terra
    If the suggestion to hold down the mouse doesn't work...

    Follow the instructions in the Apple Knowledge Base article #106752 .
  8. zer0army thread starter macrumors regular

    Jan 28, 2003

    Apparently he was able to open the door and slide a paper clip into the pin hole of the drive, which opened it and he was able to take out the disc.

    thank you




    for your tip on the pin hole manual eject which did the trick, and thanks to everyone eles for your input in helping solve this problem. not scared to asked questions for myself.......My friend really knows nothing about his computer except when it comes to FCP.....and he also can't even afford dialup at the im asking the questions for him these days:D

Share This Page