Can't get Samsung printer to work

Discussion in 'Macintosh Computers' started by Tomfinding, Dec 4, 2003.

  1. Tomfinding macrumors newbie

    Dec 4, 2003
    Help. I recommended a friend buy a Samsung Ml-1210 laser printer for their e-mac as mine is so good on my pc. Unfortunately we can't get it to work. OS 9.2, using the correct drivers, when we try to print it keeps telling us the printer is busy. We tried it on an i-mac and exactly the same happens. Any ideas - I feel responsible and don't want to lose a friend.
  2. DrBoar macrumors member

    Aug 29, 2003
    I briefly tried my 1210 printer in 9 and it worked right away. It has worked very well in OS X for several months now, both directly and through USB printer share over a DHCP network.

    Have you cleaned out the printer que in 9? If you get jobs stuck they will stall the printing and restarting the printer and computer will not help. It could be a corrupt file or a arcane paperformat way to big file that choke the printer. If you are not familiar with Mac go to the help menue at the very top of the screen and type "printer" and the extensive help files should point you in the right direction.

    If this does not work go to Samsungs web page and look for drivers later than the one on the CD.

    bst of luck, and it should work even without that:)
  3. Dreadnought macrumors 68020


    Jul 22, 2002
    Almere, The Netherlands
    This printer wouldn't happen to work with postscript 1 does it? Os X doesn't support postscript 1 unfortunately... so I can't use my old personal laserwriter NT anymore :(

Share This Page