Can't import photos or find old iPhone backups after updating to Sierra.

Discussion in 'macOS Sierra (10.12)' started by ceezy, Jan 9, 2017.

  1. ceezy macrumors member

    Joined:
    Sep 30, 2011
    #1
    Normally import photos from my iphone 6 through Preview. I can see the pics but it will not allow me to import 1 or only a handful of them. I could Import All but that crashed midway through.

    I'm also trying to get a new phone and was looking at my iTunes and it shows that my phone has never been backed up....which it has been many times.

    Noticed this all after updating to Sierra, that could just be a coincidence I guess. Sierra has been terrible for my old mid2010 MBP. Sorry, wasn't sure exactly where to post...
     
  2. Rok73 macrumors 65816

    Rok73

    Joined:
    Apr 21, 2015
    Location:
    Planet Earth
    #2
    Why don't you use the Photos app for managing your pics? You could activate iCloud Photo Library.

    As for the backup question, did you actually sync the phone with your Mac? Do you have iTunes-WLAN-Sync activated in your phone and on the Mac? Do you have iCloud backups turned on? What does iOS say under Settings/General/iTunes-WLAN-Sync?
     
  3. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #3
  4. ceezy thread starter macrumors member

    Joined:
    Sep 30, 2011
    #4
    Ok appreciate the info. I've never used Photos and normally just drag my pics from Preview to my mac. Have always been able to do bulk, I take it they changed it in Sierra?

    I never use iCloud. Under my iTunes Wi-Fi Sync it says, To Enable Wi-Fi Synching with iTunes, connect to iTunes on your computer using a cable and click "Synch with this iPhone over Wi-Fi"


    Appreciate the tips. Everything normally works well for me, but after moving to Sierra my old system hasn't been doing well. mid2010 MBP, so I'm due for an upgrade, but want to keep this one as long as I can.

    Thanks again for the tips.
     
  5. elf69 macrumors 68020

    elf69

    Joined:
    Jun 2, 2016
    Location:
    Cornwall UK
    #5
    i have a 2010 macbook NOT pro running sierra really well.
    you should be ok.

    strange why your backups have gone.
     
  6. ceezy thread starter macrumors member

    Joined:
    Sep 30, 2011
    #6
    Not sure about that, have had Sierra since it came out and have been disappointed. Slow and constant beachballs, Safari was normally snappy and it's been painfully slow and laggy. Seems like some sort of permissions or something have gone flukey? Don't understand why iTunes isn't working now. Can't move any music to or from my phone, despite it showing up in iTunes.
     

Share This Page