Can't install DP2 - "Couldn’t communicate with a helper application"

Discussion in 'OS X Yosemite (10.10)' started by Lukeit, Jun 17, 2014.

  1. Lukeit macrumors regular

    Joined:
    Feb 28, 2011
    Location:
    Shanghai, China
    #1
    While trying to update to DP2, I keep getting this error from the App store: An error has occured: Couldn’t communicate with a helper application"

    Anyone has a hint on what to do? What could it be and how to get around it?
    Currently I am again downloading DP1 to try to reinstall and start from there, but if you have any workaround, please come forward.

    Many thanks to you all.
     
  2. redetection macrumors newbie

    redetection

    Joined:
    Nov 3, 2013
    Location:
    Russia
    #2
    there is command line utility called softwareupdate, use it for this time.
    Code:
    $ softwareupdate --install --all
     
  3. Lukeit thread starter macrumors regular

    Joined:
    Feb 28, 2011
    Location:
    Shanghai, China
    #3
    Thanks very very much!
     
  4. dev-click-com macrumors newbie

    Joined:
    Jun 18, 2014
    #4
    Worked perfectly no problems no fuss.......

    Thank You
     

Share This Page