can't login to OS X (login window idle)

Discussion in 'General Mac Discussion' started by hakiepoo, Sep 22, 2003.

  1. hakiepoo macrumors newbie

    Sep 22, 2003
    After getting the 'You must restart your computer...' message, I restarted and the Mac stopped at the blue screen. I haven't got the OS cd but I have tried the following things:
    1. safe boot (didn't help)
    2. started in single-user mode and typed the following:
    mv /var/db/SystemConfiguration/preferences.xml preferences.old
    then reboot (didn't work)
    3. single-user mode and typed:
    mv /Library/Preferences/ preferences2.old
    the reboot. (the result of this was that it got to the login window (i normally have automatic login) and i typed in my username and password. The login bar then 'spins' without anything happening.

    I've also tried the fsck command without success. Any ideas would be much appreciated.


    p.s I'm on a G4 dual proc running OS X 10.2.2
  2. Caspa macrumors member

    Apr 11, 2003
    You're not running Norton Systemworks 3 are you? I recently had the problem of a blue screen and not being able to login shortly after installing it (on a 12" PB), and so did my dad (17").

    No idea what causes it and how to fix it tho, both of us formatted and havn't had a problem since. :confused:
  3. hakiepoo thread starter macrumors newbie

    Sep 22, 2003
    Nope. No Norton Systemworks running. Seems to be quite a tricky one...
  4. mico macrumors newbie

    Jul 2, 2003
    I think what you might have to do is go to disk utility with the install cd (which you said you don't have). I had this problem when i clean installed an old mac g3 powerbook with os x and I got that shut down your computer prompt. i went to repair permissions with the install disk but it kept crashing during the repair. I had to verify disk permissions first then repaired and all was well again. Another note was when i started opening up applications and i opened up FCP3 and that gray box came up again saying I had to shut down. I restarted and it opened okay. I then deleted the preference files for FCP and have had no problems since. Hope this helps.
  5. hakiepoo thread starter macrumors newbie

    Sep 22, 2003
    Have tried repairing from disc utility now, but that didn't help. I also tried to verify and repair permissions, but I'm still not able to log in. Will have to pay an expert to sort it out I'm afraid - hopefully I'll get a healty G4 i return. Thanks for all your help.

Share This Page