Can't Sleep (man, am I tired)!

Discussion in 'Macintosh Computers' started by WCat, Oct 7, 2004.

  1. WCat macrumors member


    I know somebody has the answer for this one. I have a late-model 1.33 GHz 17" PB. Works great, but somewhere in the last 3 months I've lost the ability to sleep from the energy saver settings in system preferences. By that, I mean that it sleeps fine if I close the lid or select "sleep" from the blue apple menu, but not if I just leave it alone until energy saver is supposed to time out and send the sandman.

    I've tried:

    --Resetting the PMU several times.
    --Fixing permissions.
    --Changing energy saver to sleep after 3 minutes. Display blacks out as it should, but no sleep. Tried it both on AC power and battery modes.
    --Changing energy saver to "never sleep", locking the setting, rebooting, unlocking it, then changing it back to some other time, locking it again, rebooting, noting that it still didn't work, blah, blah...
    --Creating a new admin account and changing energy settings from that account. Again, screen blanking follows the time I set on the slider, but no sleepy.
    --Searching for some power-related pref. Trashed a few, but no success.
    --Disabling any apps or daemons that looked like they might be trying to keep me awake (note: not sure I got 'em all--could still be the root cause).

    Done a few other futile things, too. I know it's gotta be an OS thing, but I was hoping to avoid reinstalling it as a last, desparate move. My PB is otherwise the best computer purchase I've ever made. Even this is just a very minor annoyance. :)

    Any and all suggestions appreciated.
  2. crazzyeddie macrumors 68030


    Dec 7, 2002
    Florida, USA
    I think I'm having the same problem on my TiBook... I have Energy Saver set to sleep after 1 hour, but i took at 3 hour nap today, and when i got it it was still on...
  3. crazzyeddie macrumors 68030


    Dec 7, 2002
    Florida, USA
  4. bubbamac macrumors 6502

    Dec 24, 2003
    I had the same problem. I just disabled Virex from the startup menu, and voila! My PB goes to sleep like it's supposed to.

    Next step is to re-enable Virex (I didn't see any appreciable speed difference), and see if the problem returns.

    I've gotten used to doing the "Power" - "S" combo when I get up, so it's not a problem anyway.
  5. WCat thread starter macrumors member


    Ah, now there's a thought! I'm not using Virex on this particular computer, but I am using Norton. I'll try disabling some of its "features" and see what happens.

    (Thanks CrazyEddie for the bump also :cool: )

  6. WCat thread starter macrumors member


    Found the Problem

    I should have guessed that it would be an HP printer driver problem! I've had lots of problems with HP drivers and software in the past with Windows-based PC's, so why should it be any different on Macs?

    In case anyone is interested, this is what I did:

    1. Bring up terminal. Type "top" (w/o quotes, of course) then hit <enter>

    2. The "top" command shows all of your running processes. This is different from doing <CMD><option><esc> all at once, which brings up the "force quit" window that shows running APPLICATIONS only.

    3. I looked for processes that might be potential problems. Since I use Norton, I saw some of those for virus protection. I turned them off from Norton's menu, then looked again. My plan was to stop likely processes one at a time, then see if the PB would go to sleep (power saving was temporarily set to 2 min sleep).

    4. To kill a process, note the PID number at the beginning of each line where the process is running. Part of the process's name is also shown.

    5. Hit <ctrl>C to exit TOP, then type "kill xxx" w/o quotes, where xxx is the process number you'd like to kill. In my case, the process named "HPprin..." (can't remember the name) had a PID of 238, so I typed "kill 238" then <enter>.

    6. Unless you killed a critical process (good luck on that), nothing very noticeable should happen. You get a new command prompt and that's it.

    7. Type "top" again. Note that your killed process and its PID should not show up in the list. You killed it. Hit <ctrl>C to exit top again and close the terminal window.

    8. Sit back and wait for the sleep light to come on after 2 minutes. Hey, it works! Stinkin' HP and their crummy programming! I assume that they are keeping the system awake to check for printer status, but geez guys...even when the printer is not connected?? And why not do a better job monitoring external functions w/o allowing the system to sleep??

    9. Now the hard part--go figure out how to make the process not start again on the next reboot. You may have to uninstall the driver and use a 3rd party driver, or you may have to live with it, but at least be aware of why these idiots decided to disable one of the really nice automatic features in OS X. Better yet--go buy a non-HP printer. Maybe they'd get the hint after sales begin to drop off.

    By the way, did I mention how much I hate HP's software!!!! :mad:

    Oh well,


Share This Page