Can't transfer files to USB over 2gb

Discussion in 'macOS High Sierra (10.13)' started by nick2903, Jan 13, 2018.

  1. nick2903 macrumors newbie

    Joined:
    May 5, 2014
    #1
    Hi I've recently discovered an issue which wasn't a problem until recently.
    I can't seem to transfer files larger than 2gb (but under 4gb) to any USB. I have tried multiple formats (fat32, mac OS extended), different files, and different USBs, and I receive a message stating...

    "The item “*file name*” can’t be copied because it is too large for the volume’s format."

    If the file was over 4gb I can understand due to the fat32 limitations, but 2gb?? I have never heard of that issue before!

    I am running High Sierra 10.13.1 on a 2014 macbook pro.
     
  2. aristobrat macrumors G5

    Joined:
    Oct 14, 2005
    #3
    IIRC, that’s an issue with Finder. Folks have said using Terminal (and the cp command) or a alternative to Finder (like PathFinder) work.
     
  3. mattguy10 macrumors 6502a

    mattguy10

    Joined:
    Aug 18, 2010
    #4
    This is what I use to get around this. The free version works fine for what you’re trying to do.

    https://mac.eltima.com/file-manager.html
     
  4. chabig macrumors 603

    Joined:
    Sep 6, 2002
    #5
    It sounds like you need to reformat the USB drive. I know you said you tried multiple formats, but it has to be that. Make sure the partition scheme is GUID and the format is HFS Extended, Journaled. It should work. The problem with FAT is probably file size.
     
  5. ZapNZs macrumors 68020

    ZapNZs

    Joined:
    Jan 23, 2017
    #6
  6. Roger Wilco macrumors newbie

    Roger Wilco

    Joined:
    Dec 11, 2018
    #7
    I'm currently having the same problem with an Seagate 4Tb drive. OS 10.13.3 Macbook Pro. The strange part is that I do have files on the drive that are larger than 2 gb, but as of a few months ago, it's not letting me copy files.
     
  7. Bugsi macrumors newbie

    Joined:
    Dec 14, 2018
    #8
    It's a defect in the Finder in 10.13. Use the terminal and cp command and you'll be fine.
     

Share This Page

7 January 13, 2018