Can't update iPhone 4 apps in 5.0.1

Xscapes

macrumors regular
Original poster
Oct 16, 2011
166
9
New York
For some reason after 5.1 release, i can't update my apps in my iPhone 4 which is still in 5.0.1 every time i click update the apps just say Waiting and nothing happen. I tried restart the phone and do it another day, it still not work.
 

saving107

macrumors 603
Oct 14, 2007
6,369
14
San Jose, Ca
I had this issue last week, the only way I was able to fix it was by updating the app in iTunes, and then plugging my iPhone to iTunes and updating that way,
 

bar55nelson

macrumors newbie
Mar 29, 2012
1
0
Can't update Apps

How does one update Apps on iTune? I can't update the Apps on my iPhone either. I get a message: "Cannot connect to iTunes Store" even though I can add a new App with no problem.
Thanks.:confused:
 

BFizzzle

macrumors 68020
May 31, 2010
2,442
0
Austin TX
For some reason after 5.1 release, i can't update my apps in my iPhone 4 which is still in 5.0.1 every time i click update the apps just say Waiting and nothing happen. I tried restart the phone and do it another day, it still not work.
had this problem recently

•iPhoneBrowser or iExplorer

•You do not need a jailbroken device to do this


1.Plug your iPod/iPhone/iPad into your computer. You don't need to let it sync

2.Open iExplore and let it load

3.Open the directory labeled "Downloads" (On jailbroken devices that should be "/var/mobile/Media/Downloads")

4.Delete all files in this folder*

5.Close iExplore and reboot your device


if its jailbroken just use ifile