Can't use MacBook with external DVI monitor with lid closed after update

Discussion in 'MacBook' started by dr.devious, Dec 17, 2008.

  1. dr.devious macrumors regular

    dr.devious

    Joined:
    Nov 30, 2008
    Location:
    Truckee Meadows, NV
    #1
    Can't use MacBook with external DVI monitor with lid closed after performing the 10.5.6 update :mad: It worked fine before the update and that is the way I use my MacBook while I am at home. Now when I plug in the external monitor and close the lid it puts the computer to sleep, then I hit my mouse or wireless keyboard it wakes up the MacBook and displays the login on the external monitor and then goes back to sleep. It just continues in this cycle :(
     
  2. jmb667 macrumors regular

    jmb667

    Joined:
    Aug 7, 2008
    Location:
    Philomath, OR, USA
    #2
    Interesting...I have a Macbook and I upgraded when it was available...haven't had any problems with my external display. I assume you've checked all your connections and everything else?
     
  3. Camoischaos macrumors member

    Joined:
    Nov 30, 2008
    Location:
    Southern California
    #3
    I have this problem a couple times but what i did was just shut the computer down then boot it up shut the lid and it seemed to fix the problem. And when it wont wake up from sleep from time to time i just turn the keyboard off then back on and it fixes that too. You can try those tell me how it works.
     
  4. RedTomato macrumors 68040

    RedTomato

    Joined:
    Mar 4, 2005
    Location:
    .. London ..
    #4
    Sometimes I've had clamshell mode fail, then realised 5 minutes later that the power or mouse was unplugged :eek:

    but I have also had similar fail cycles like the person above - the laptop wakes up, the monitor comes on then it all goes back to sleep.

    A reboot has always sorted it out. You could also try re-detecting the displays in System Preferences.
     
  5. josep macrumors newbie

    Joined:
    Jan 3, 2009
    #5
    I have the same problem... When the macbook is plugged, then the closed-lid mode works, but it does not when I am using the battery. I have checked all connections, and they are ok. Any suggestions?
     
  6. jmb667 macrumors regular

    jmb667

    Joined:
    Aug 7, 2008
    Location:
    Philomath, OR, USA
    #6
    It's designed to only work when plugged in; not on battery power.
     
  7. RRutter macrumors 6502

    Joined:
    Jan 1, 2008
    Location:
    Austin, TX
    #7
    From what I know, when the screen is DOWN that put it in sleep mode..

    Not sure, check this thread out.. Good luck!!
     
  8. dfjdejulio macrumors newbie

    Joined:
    Jun 6, 2012
    #8
    I just took some time to work on this issue, and have finally solved it for myself.

    TL;DR summary: from console mode or "su" from another account or something, while not graphically logged in as "yourself", go to ~/Library/Preferences/ByHost/ and delete every file that begins with "com.apple.windowserver". It all starts to work again.

    Full explanation, including my symptoms/diagnosis:

    I have a monitor that has both DVI and VGA inputs. The behavior I was getting was, when I used a VGA cable, everything worked with the lid closed. When I used a DVI cable, the system went to sleep with the lid closed. But I had to use the VGA cable to connect another computer, and was forced to use the DVI cable for a time, which is what forced me to sit down and diagnose this.

    Here's the behavior I observed:

    Power down the machine, connect all the right cables, open the lid, press the power button, and immediately close the lid before boot starts, and the bootup process used the external monitor, and the login screen used the external monitor, no problem. But log in, and the system immediately goes to sleep.

    Open the lid and it wakes up and both screens work. Log out. Close the lid and the login window appears on the external screen just fine.

    My machine has "guest login" enabled -- I tried logging in as the guest. It worked. The guest was able to use just an external monitor connected by DVI.

    I also do my normal work on a non-admin account, and keep an admin account around for when I need it. Logging in on the admin account, it worked. The problem was only with my ordinary account.

    So I figured it was likely some preference, hidden or otherwise, that differed between my day-to-day account and from the default. So I started clicking around in various preference-setting tools and seeing which files changed. I then opened each file with a plist editor to make sure that there weren't critical, unrecoverable things stored in them.

    For each file that looked like it might be the culprit but which also looked "safe" to delete, I logged out, logged into my admin account, opened the terminal, used "su" to switch to my main account, and nuked the file.

    The one that fixed the problem was the "ByHost" version of "com.apple.windowserver". The main data that I lost was my preferred display resolution. My eyes are getting old, so sometimes I set the resolution to less than native, to make everything bigger.

    After logging in, I changed the resolution again. For some reason, certain values made the external display shut down. But I found I could fix it by logging out and removing that file again, so I experimented a bit. Native resolution was always safe, as were some other resolutions with exactly the same aspect ratio, as were the HiDPI modes that were exactly half any "normal" mode that worked.

    Anyhow. Nuke that file while not logged in via the GUI and see if it doesn't solve your problems. And please let us know either way.
     

Share This Page