CarPlay CarPlay adapter to convert to wireless CarPlay?

Status
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.

Skmzatlanta

macrumors newbie
Aug 27, 2020
9
3
Skmzatlanta, Infotainment 3 Plus and MyLink 3 Plus are exactly the same thing, i.e., GM RPO code "IOS". Your 2020 Camaro and our 2019 Silverado and 2020 Colorado all have the same hardware. You have also confirmed that 0804 and 0810 both work on the dongle in your car (albeit not perfectly), and I am running 0804. So we are synchronized on two of three degrees of freedom.

The only thing left is the GM infotainment software... and I did not recognize the string format of the software version info you provided in post #4123 above. Did you get your information from the same screen shown in my attached photos from our two trucks?
Here you go Dusty
 

Attachments

DustySilverado

macrumors newbie
Sep 12, 2020
8
1
Atlanta Metro
Here you go Dusty
Thanks Skmzatlanta. It looks like your car may be running the original software, and while its W119 build is timestamped 12-Sep-2019, our V807 is lower by sequence but timestamped later on 23-Sep-2019. While it is clear that your Camaro and our trucks are running different software and this could be the reason our systems behave differently than yours, I will surf over to the GM Truck forum to confirm my understanding of the load build numbering scheme.
 

CopyChief

macrumors regular
Oct 9, 2007
185
83
My Carlinkit USB-C with the latest September software keeps crashing after the end of each song. It freezes and reboots the infotainment system every time on my Mazda 6.
The dongle never worked as intended with any of the software updates, it keeps having connection problems or crashes.

Is there someone in the forum who has had good luck using the Carlinkit USB-C device or any other type of dongle in their Mazda?
I have a 2018 Mazda CX-5, and experienced the same with the range of August and early September updates. It worked for a bit (sometimes), and... just as I started to feel confident, the whole infotainment system would restart. One recent update seems to have completely "bricked" the dongle – now it won't connect at all. No lights, no wifi or bluetooth signal, nothing. I'm guessing this adventure is over for now.
 

shadowmyst1975

macrumors member
Aug 2, 2020
68
17
Thanks Skmzatlanta. It looks like your car may be running the original software, and while its W119 build is timestamped 12-Sep-2019, our V807 is lower by sequence but timestamped later on 23-Sep-2019. While it is clear that your Camaro and our trucks are running different software and this could be the reason our systems behave differently than yours, I will surf over to the GM Truck forum to confirm my understanding of the load build numbering scheme.
That is correct. GM cars and trucks use different branches of the core Mylink software.
 

Fluke1

macrumors member
Jul 4, 2020
43
8
I have updated my Cplay2air dongle to 8.22 a while back to lose the delay timer in my GM Mylink 2 vehicle. It worked OK but not great as far as connectivity goes, so I went back to 8-4. Now 8-4 has issues too, I cannot run both Waze/Google Maps and muisc simultaneously or else it'll start stuttering and eventually crash or freeze after 10 minutes or so. Some times it works ok but more often than not it won't.

Anyone with experience with another firmware that works better in GM vehicles? The delay timer harness doesn't bother me anymore. I just need to get rid of the stuttering if all possible.
 

shadowmyst1975

macrumors member
Aug 2, 2020
68
17
Updated to final iOS 14. Very fast. This screen was new but just selected music from the phone and it kicked in.
I'm guessing you downloaded it through the beta program since it is not released yet to the general public (well, supposedly it is starting to release as I click on "Post Reply".)
  • Cupertino, California: 11:30 a.m. PDT - 1:00 p.m. PDT
  • New York, New York: 2:30 p.m. EDT - 4:00 p.m. EDT
  • London, United Kingdom: 7:30 p.m. BST - 9:00 p.m. BST
  • Delhi, India: 12:00 a.m. IST - 1:30 a.m. IST (Sept 17th)

Tried rebooting the phone & device?
 
Last edited:

LarryJoe33

macrumors 68020
Jul 17, 2017
2,121
728
Boston
I'm guessing you downloaded it through the beta program since it is not released yet to the general public (well, supposedly it is starting to release as I click on "Post Reply".)
  • Cupertino, California: 11:30 a.m. PDT - 1:00 p.m. PDT
  • New York, New York: 2:30 p.m. EDT - 4:00 p.m. EDT
  • London, United Kingdom: 7:30 p.m. BST - 9:00 p.m. BST
  • Delhi, India: 12:00 a.m. IST - 1:30 a.m. IST (Sept 17th)

Tried rebooting the phone & device?
Yup, I got it pushed first thing this morning EST as a dev beta tester. The schedule above is the latest for general public.
 

shadowmyst1975

macrumors member
Aug 2, 2020
68
17
Yup, I got it pushed first thing this morning EST as a dev beta tester. The schedule above is the latest for general public.
WatchOS 7 & iOS 14 aren't available to me yet in CST.

In any case, I'm not sure what could have caused the issue. Maybe the recent big releases have been to update for iOS 14? Have you checked to see if there any any apple services down?

Edit: iOS 14 is linked on iClarified now.
 
Last edited:

shadowmyst1975

macrumors member
Aug 2, 2020
68
17
Holy Potatoes!

The pioneer track change bug is a lot worse with the public release of iOS 14. It used to be tolerable but after upgrading it now skips 10-15 songs in 1-2 seconds.

Need to try a clean install of iOS 14 using my MBP to test and see if it still does that.

Edit #1: Guess what is back? Yep, both the carplay2air unit and carlinkit usb-c unit are thinking my climate controls (specifically fan speed control) and back up camera are head unit function controls again.

Edit #2: macOS 10.5.6 made me install a software update first before it would let me upgrade my phone to iOS 14.... even though iOS 14 was already installed on my phone. I'm assuming it was the macOS equivalent of updating iTunes to support the new iOS.

Edit #3: Clean install did return it to the “normal” 1 song every 1-2 seconds track change bug. It also fixed the reappearing head unit control bug.
 
Last edited:

Kheops74

macrumors newbie
Sep 17, 2020
2
0
I think i saw someone with the same problem. I have a carlinkit with a GM car. Firmware 08,22 solve the problem where i always have to unplug and plug the dongle when i start the car. Last week, i receive a new firmware 09.sometihing over the air (OTA). After the update, the version is 08.04 (the bug is back). Any way to put the last firmware (newer than 08.04)? Where i can download it?

P.S. i saw firmware from 112.74.112.110 but the dongle stay at 08.04. Maybe i do something wrong.
 

DarkEvilRivas

macrumors member
Jul 30, 2020
40
13
[QUOTE = "Kheops74, publicación: 28905534, miembro: 1233071"]
I think i saw someone with the same problem. I have a carlinkit with a GM car. Firmware 08,22 solve the problem where i always have to unplug and plug the dongle when i start the car. Last week, i receive a new firmware 09.sometihing over the air (OTA). After the update, the version is 08.04 (the bug is back). Any way to put the last firmware (newer than 08.04)? Where i can download it?

 

Mike Kempski

macrumors newbie
Sep 17, 2020
1
0
I think i saw someone with the same problem. I have a carlinkit with a GM car. Firmware 08,22 solve the problem where i always have to unplug and plug the dongle when i start the car. Last week, i receive a new firmware 09.sometihing over the air (OTA). After the update, the version is 08.04 (the bug is back). Any way to put the last firmware (newer than 08.04)? Where i can download it?

P.S. i saw firmware from 112.74.112.110 but the dongle stay at 08.04. Maybe i do something wrong.
same problem. carlinkit fw 8.04 and i cannot update to anything newer. music crashes when waze is on after few minutes and have to remove it and plug back in every time car starts
 

Kheops74

macrumors newbie
Sep 17, 2020
2
0
[QUOTE = "Kheops74, publicación: 28905534, miembro: 1233071"]
I think i saw someone with the same problem. I have a carlinkit with a GM car. Firmware 08,22 solve the problem where i always have to unplug and plug the dongle when i start the car. Last week, i receive a new firmware 09.sometihing over the air (OTA). After the update, the version is 08.04 (the bug is back). Any way to put the last firmware (newer than 08.04)? Where i can download it?

Nice! was able to apply 08.22. It propose to update to 09.05.1602 (NO WAY). I will test it tonight but the dongle reconnect at startup.

Which version after 08.22 is the most stable?
 
Last edited:

slypx

macrumors member
Aug 24, 2017
44
27
Updated to final iOS 14. Very fast. This screen was new but just selected music from the phone and it kicked in.


It also showed up on general public release too. Explanation I can see is that following the update, when you open the Music app there is the « What’s New » splash screen to acknowledge that CarPlay will not bypass. Once done all is good.
 
Last edited:
Status
The first post in this thread is a WikiPost, and can be edited by anyone with the appropriate permissions.
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.