CarPlay CarPlay asks for permission from USB device often

MrMister111

macrumors 68040
Original poster
Jan 28, 2009
3,071
209
UK
It seems, sometimes randomly, that I if in my iPhone Xr, and on screen says can't start CarPlay and then I notice on my iPhone it states "allow access to USB accessories" I have to unlock iPhone and then works.

It seems to do this after I've restarted my iPhone, but sometimes randomly. Is this correct?

The time I forget is when I plug it in, drive off then start CarPlay and it won't start and then can't fiddle with iPhone until is stop.

Normal?
Thanks
 

Solver

macrumors 65816
Jan 6, 2004
1,029
2,961
USA
It seems, sometimes randomly, that I if in my iPhone Xr, and on screen says can't start CarPlay and then I notice on my iPhone it states "allow access to USB accessories" I have to unlock iPhone and then works.

It seems to do this after I've restarted my iPhone, but sometimes randomly. Is this correct?

The time I forget is when I plug it in, drive off then start CarPlay and it won't start and then can't fiddle with iPhone until is stop.

Normal?
Thanks
Did you try this,
https://www.tekrevue.com/tip/disable-usb-restricted-mode-ios-12/
 
  • Like
Reactions: MrMister111

MrMister111

macrumors 68040
Original poster
Jan 28, 2009
3,071
209
UK
Ah I see thanks for that, it's understandable really I suppose.

I'd rather keep USB accessories enabled, and maybe if I just unlock it with FaceID before getting in car it will work then?

Wonder if Apple could not just allow CarPlay to bypass this, although maybe then they'd find a way to exploit this!

Thanks
 
Last edited:

MrMister111

macrumors 68040
Original poster
Jan 28, 2009
3,071
209
UK
Well unlocked on way to car, plugged in started off and screen said need to check phone or something.

Unplugged/plugged in but still no good. Looked at screen and had the "unlock to use USB accessories".

Had to unlock iPhone and then worked straight away.

So not sure now what's going on and why I get this message.
 

MrMister111

macrumors 68040
Original poster
Jan 28, 2009
3,071
209
UK
It can seem random. And it seems some people get asked every time depending on specifics.

https://help.apple.com/deployment/mdm/#/mdmc622d929c
Thanks, just read that doc and it must be the 3 day one then as sometimes I don't use CarPlay all the time, and I mostly wirelessly charge now, so presume even a wired charge would override it?

"In addition, in iOS 12, if it’s been more than three days since a USB connection has been established, the device will disallow new USB connections immediately after it locks. This is to increase protection for users that don’t often make use of such connections. USB connections are also disabled whenever the device is in a state where it requires a passcode to re-enable biometric authentication."
 
Last edited:

bransoj

macrumors 65816
Jul 31, 2013
1,162
330
I think this three day thing is the issue i'm sometimes seeing with me needing to unlock the iPhone to allow Carplay to work despite me setting the "Allow Carplay when Locked" to on. I had to do it this morning and the last time my 6S was plugged into the car was Friday and at home its charged from a USB socket built into one of our wall sockets which probably doesnt count. I was out in the car on Saturday but never plugged it in and never went out in the car yesterday.

I've changed the option under Touch ID settings to allow USB when locked and will see if it makes a difference.
 

MrMister111

macrumors 68040
Original poster
Jan 28, 2009
3,071
209
UK
Well its still a bit random for me, still asking for unlock even if I have on the iPhone, but not connected to CarPlay radio system.

So maybe there is a 3 day if it hasn't been connected to my CarPlay radio?
 

MrMister111

macrumors 68040
Original poster
Jan 28, 2009
3,071
209
UK
Still not working, or not as I want anyway. Unlocked iPhone, locked, got in car, plugged in, message on car touchscreen says needs unlocking for access.

Checked iPhone screen, says unlock to allow accessories, unlock and CarPlay works....I've contacted Apple support to see what they say
 

xraydoc

macrumors demi-god
Oct 9, 2005
7,744
1,889
192.168.1.1
Still not working, or not as I want anyway. Unlocked iPhone, locked, got in car, plugged in, message on car touchscreen says needs unlocking for access.

Checked iPhone screen, says unlock to allow accessories, unlock and CarPlay works....I've contacted Apple support to see what they say
I don’t think just simply unlocking the phone is enough to enable USB devices. Must be unlocked after plugging in said USB device, not before. At least that’s how it seems to me.

I only turn the USB lockout on when I’m traveling and won’t be plugging it in to my car. Otherwise, I leave it off since I use CarPlay frequently.
 

MrMister111

macrumors 68040
Original poster
Jan 28, 2009
3,071
209
UK
I don’t think just simply unlocking the phone is enough to enable USB devices. Must be unlocked after plugging in said USB device, not before. At least that’s how it seems to me.

I only turn the USB lockout on when I’m traveling and won’t be plugging it in to my car. Otherwise, I leave it off since I use CarPlay frequently.
Yes suppose could try that. Prefer any security features to be on, and I normally wirelessly charge now so doesn't get plugged in. Be better if it could allow trusted devices though and remember them. Just have to live with it suppose.

Thanks
 

BigMcGuire

Contributor
Jan 10, 2012
6,050
7,586
California
My wife and I both have Civic 2018 with CarPlay. My car works fine, but hers had a very similar situation to what you posted above. We replaced her iPhone cable with a different one (an actual Apple cable) and all her problems went away. I'm using an Anker cable with no problems, but her car doesn't like it.

She'd be listening to music then it would disconnect and ask her to unlock her phone randomly throughout the drive. Hasn't had it happen since I put an official Apple cable in her car.

Wish there was a way to do CarPlay without needing to physically connect. I much prefer bluetooth.
 

MrMister111

macrumors 68040
Original poster
Jan 28, 2009
3,071
209
UK
My wife and I both have Civic 2018 with CarPlay. My car works fine, but hers had a very similar situation to what you posted above. We replaced her iPhone cable with a different one (an actual Apple cable) and all her problems went away. I'm using an Anker cable with no problems, but her car doesn't like it.

She'd be listening to music then it would disconnect and ask her to unlock her phone randomly throughout the drive. Hasn't had it happen since I put an official Apple cable in her car.

Wish there was a way to do CarPlay without needing to physically connect. I much prefer bluetooth.
Ah ok I'll try a official Apple cable thanks, I use a short non Apple at mo, works fine after unlocking, and for a few days, so thought this cable was fine, just means that the cable is far to long for what I really need then though. Being an MFi cable means it should be the same as an Apple cable though.

Agree I really wish wireless CarPlay was more common, it'll come and much much more convenient, I don't plug in for short journeys, then get a text though and wish was plugged in....
 
  • Like
Reactions: BigMcGuire

dwfaust

macrumors 604
Jul 3, 2011
6,574
7,406
Ah ok I'll try a official Apple cable thanks, I use a short non Apple at mo, works fine after unlocking, and for a few days, so thought this cable was fine, just means that the cable is far to long for what I really need then though. Being an MFi cable means it should be the same as an Apple cable though.

Agree I really wish wireless CarPlay was more common, it'll come and much much more convenient, I don't plug in for short journeys, then get a text though and wish was plugged in....
I got the Alpine ILX-107 wireless CarPlay head unit and it is sweet... wife's Ford Edge uses Ford/Sync/wired connection... works great, but wireless is better.

And FWIW, I use Anker mFi cables almost exclusively every where I need a lightning cable... no issues.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.