Cd Rom Hell!


macrumors 68020
Original poster
Dec 3, 2001
Ever since I installed iTunes my internal CD Rom can't read any of the CDs I've burned over the past 3 years!

It can't even read new ones I've burned from disk images as HFS format CDs, it's got no problem reading a pressed CD in Mac OS format though.

If I put a mixed mode or CD Extra disk in it complains about it, it won't read any burned CDs even if they worked fine before.

I've even tried disabling the Adaptec UDF extension, all the iTunes extension and updating to OS 9.1

I've even manually installed the following drivers from the OS 9.1 installer using tomeviewer and it can't sort the problem out :

Apple CD/DVD Driver
Apple Photo Access
Audio CD Access
Foreign File Access
ISO 9660 File Access
UDF Volume Access

I did use a patch to get iTunes to work under OS 8.6 before I got OS 9 and later updated to OS 9.1, it's like something's permanently wrecked my CD Rom and no amount of extension tweaking and updating can sort it out, at least as far as my knowledge goes. It's an old model, 300Mhz beige G3 Desktop bought in early '98. The CD Rom has always been kind of clunky but it's fine for audio CDs and pressed data CDs, it's just CDRs it goes nuts with.

I can't boot from the external CD Rom either, for defragging my system partition and checking for viruses, I have to boot from a zip disk.

I can start up from my internal CD rom with the Mac OS 8.6 updater CD but because my original system CD was wrecked and my current one is a CDR of the Mac OS 9 CD, that's not an option.

Anyone got any idea how to solve this ? It's driving me crazy.


Moderator emeritus
Mar 25, 2002
London, England
Re: Cd Rom Hell!

Originally posted by barkmonster

I did use a patch to get iTunes to work under OS 8.6 before I got OS 9 and later updated to OS 9.1
Arn't we up to 9.2.2 now? I think we are :confused:
I've havn't used OS9 in so long I havn't kept up with the updates, but I'm sure the last was to 9.2.2.


macrumors 68020
Original poster
Dec 3, 2001
wouldn't it just be the same with OS 9.2.2 ?

I mean OS 8.6 worked fine till I installed iTunes, then I removed it, updated to OS 9, installed iTunes again (iTunes 2 this time). Still no joy on reading the CDs that were fine before, then I updated to OS 9.1 and it's not solved anything.

It's not the fact my OS is old that's causing the problem, I tried some of the CDs in a really old mac running OS 8.0 and it could read them all fine so it's got to be something other than out of date drivers that's causing the problem.

with the same extension set I'm using now, I checked the connections to the CD Rom, put a CD in that's causing the problem, booted up and suddenly it could read the CD fine. I ejected it, and tried to mount it again and it gave the error I keep seeing about it being unreadable. I restarted again, inserted the CD again when it got the desktop and still got the error. I'm thinking it could be hardware related but as it was software that caused the problem, it's got to be software that will fix it.


macrumors 68030
Nov 4, 2001
Kent, UK
Have you tried the standard procedures for OS 9? Try restarting without extentions, see if it works then. Also, zap your PRAM whilst you're at it.


macrumors 6502a
Jul 12, 2001
try with this:
disable 'Authoring Support ' extension
and enable 'Toast CD Reader' extension


macrumors 601
Oct 4, 2001
Natick, MA
Update to 9.2.2 and run the software update control panel several times (until it comes up with no updates needed at least twice).

Are you unable to read data AND music cd's??? Which version of Toast are you running?? Get the latest if you don't already have it (Toast Titanium).

Also, disable the cd burner/authoring extensions once you have toast installed (they don't play nice together for the most part). Have you run the Apple Hardware test cd? Or did your system not come with one? Your cd drive might have gone bad (died). It has been known to happen over time, and with extensive use.


macrumors 68020
Original poster
Dec 3, 2001
thanks! I think my CD Rom is broken

I tried all the extension tweaking, booting without extensions and zapping the PRAM several times, it seems nothing's going to get it working and the whole iTunes thing was just a coincidence.

This is what it does with various CDs :

Audio CD : NO problem, mounts in seconds

Mixed Mode Audio CD (Linkin' Park Single for "In The End") : Throws up an error about the disk being unreadable, clicking eject on the dialogue does nothing and it mounts fine.

Burned Data CDR or CDRW : Throws up an error about the disk being unreadable, I can't solve this.

Pressed Data CD : no problems

I'm not sure if I should get a CD drive cleaning kit and try that, I'm thinking it's just that the drives had it, The CD player on my old hi fi started doing similar things with burned audio CDs right before it packed up so I'm guessing it's something wrong with the drive.

With my mac being a beige G3 with no slave support, this could actually be a positive thing, if I can find a bootable SCSI CD ROM to replace it, I can free up the EIDE channel the CD ROM is currently connected to an add a second hard drive for audio work. Obviously this is going to cost me a bit but I'm sure they still make SCSI CD Roms, I could maybe get a pulled CD Rom drive from an old mac that would work or something.