CD-ROM not responding

Discussion in 'Macintosh Computers' started by jennifer34, Oct 12, 2003.

  1. jennifer34 macrumors newbie

    Oct 12, 2003
    I just started getting a message saying "Apple CD-ROM drive not responding. Check connections, etc....." and I have no idea why. My CD-ROM is internal, so I don't know what connections could be off. I do have an external CD burner, but I checked that and it's connections are fine. (By the way, I'm on a G4 PowerMac.)
    The CD-ROM was working fine last time I used it, a few days ago. (I got the error message when I tried to launch Apple CD player, after putting in an audio CD and not seeing the CD icon pop up on the screen as it usually does.)
    Possible causes I can think of, although one of these is a real stretch:
    1. I accidentally left a disc in the drive for awhile (I thought I had taken it out.) It was the FontReserve install CD; I was reinstalling FontReserve because I've been having all kinds of problems with what I perceive to be a conflict with FontReserve and Adobe Illustrator. I removed that CD by pushing the eject button on the tower, since I couldn't drag it to trash or use the eject command, since the computer wasn't recognizing anything in the drive. So then I tried putting the disc back in, to see if maybe it just wanted me to remove that particular disc the "right" way. No dice.
    2. The aforementioned conflict between FontReserve and Illustrator, though I don't see how that could affect my CD-ROM.

    I've gone through all the MacHelp topics to no avail.
    Anybody have any tips? I really appreciate any help--
  2. rainman::|:| macrumors 603


    Feb 2, 2002
    can i ask what OS you are running? since you mention apple cd player, not it's newer counterpart iTunes...

    this may be software related but is more likely hardware. you may need to open the computer and check the connections, perhaps upgrade the firmware, or your drive may be dying--

  3. jennifer34 thread starter macrumors newbie

    Oct 12, 2003
    OS 9.1

    I'm running OS 9.1.
    I'll try to open up the case and look at the connections, if I can figure out where they are! I've never done that, so this should be interesting...
    I suppose the drive could be dying, but that would be really frustrating since the computer is only about 3 years old and I was always told Macs lived forever. And it also isn't recognizing CDs in my external CD burner, so it seems like the problem is not specific to my built-in CD-ROM.
    I'm not very computer savvy-- I had to look up firmware to find out that it's "computer programs contained permanently in a hardware device (as a read-only memory)." Can you tell me where I could find out more about what type of firmware I'd need and where I would get it, if that turns out to be the problem?
    Thanks for your input; I really appreciate the help.
  4. latergator116 macrumors 68000


    Sep 30, 2003
    Providence, RI
    Do you still have applecare on the computer? If you do then I would call them if I were you
  5. jennifer34 thread starter macrumors newbie

    Oct 12, 2003

    My AppleCare ran out a few months ago, unfortunately.
  6. jennifer34 thread starter macrumors newbie

    Oct 12, 2003
    problem resolved

    just in case anyone else has this problem...

    the way i resolved it was to restore my system software from the CD. probably not the easiest or most direct way to do it, but it worked.
    i tried other stuff... checking connections, resetting PRAM, etc... to no avail.

    thanks to latergator116 and paulwhannel for their advice.

Share This Page