CD stuck in PowerBook, Help!

Discussion in 'PowerPC Macs' started by snooziums, Sep 26, 2004.

  1. snooziums macrumors regular

    Apr 30, 2004
    Evergreen State
    Okay, so I inserted a brand new blank CD into my new 12" PowerBook (with the combo drive), and the CD icon does not show up. The CD drive does spin up for a short while, however nothing happens.

    Worse yet, I cannot eject it. I have tried pressing the "eject" button, pressing and holding down the trackpad button at startup, and none of those work!

    I cannot get this darn CD out of the PowerBook for the life of me! Help!
  2. cluthz macrumors 68040


    Jun 15, 2004
    Can you see the CD in Disk Utility? ( /Applications/Utilities/)
    Try to mount it there or eject it from there..
  3. slughead macrumors 68040


    Apr 28, 2004
  4. Counterfit macrumors G3


    Aug 20, 2003
    sitting on your shoulder
    Yay for reading!

    There might be a little hole to one side of the drive's slot (that sounds so dirty... :eek: ) for you to insert an Almighty Paperclip. I'm not sure if it's actually there on the new PB's though, as I haven't found it yet on mine :confused:
  5. Timelessblur macrumors 65816


    Jun 26, 2004

    If it not there I would say it was an extermly stupid move on apple's part and a very dumb idea. It is always a very good idea to have a mechincal and manual fail safe for things like CD drives. Sometimes they just get stuck and the only way to get them out is with the almighty paperclip. That and it comes in handy when the power is dead and you want the disk out of the computer
  6. Kingsnapped macrumors 6502a


    Oct 16, 2003
    Los Angeles, CA
    Try pushing iTunes' eject button?

    btw, no paperclip hole on the powerbook. Maybe it's on the edge, inside the drive slot.
  7. reykjavik macrumors 6502

    Aug 31, 2004

    This happened to me once when I put in a warped bootleg dvd. I went to a tech support guy in Singapore (I was there at the time) and he told me to reboot into some type of terminal unix thing, I cant remember what he told me to do (i do remember i held down a couple of letters on reboot) and once in there I typed "eject" and it did a forcefull eject. That right off the bat didnt work, but when I did it again along with a thrust downwards of my laptop (why not have gravity help out a bit) the disc came out. So my point is, try rebooting while holding down the eject button, since im sure this does the same thing as that guy did for me, but while holding it down make a couple of thursting motions with the laptop to try to make the disc fly out. Believe it or not it works...
  8. OldManJimbo macrumors 6502


    Jun 1, 2004
    California Coast
    Same thing happened to me about a week into ownership of a new Rev2. I can't rememeber how (or if) I got the CD out, but I did get a new drive. Take it back your retailer ASAP - and call AppleCare before you take it in.
  9. Abstract macrumors Penryn


    Dec 27, 2002
    Location Location Location
    Put your laptop to sleep, close the lid, and drop it on your bed from a good height a few times.

    Yeah, maybe the CD placement in the drive has to get sorted.
  10. PBGPowerbook macrumors regular

    Jan 6, 2004
    I have a disc (best of the velvet underground) stuck in my rev a 12 in Pbook for about 3 months now. These do not help: itunes eject, eject button, mousedown on startup, dragging cd to trash, telling eject in open firmware, disk utility eject. I am waiting for a break in school where i can afford to be without my computer for a sucks.
  11. FuzzyBallz macrumors 6502a


    May 2, 2003
    Home of Al-Qaida
    Take the PB apart, take the optical drive out, take that apart, take disc out. If you broke the drive during the process, bring it to the Apple Store and utilize the Apple warranty. If you lose a couple screws or forgot which part goes where during reassembly of optical drive, use superglue.
  12. kasei macrumors 6502a


    Dec 30, 2003
    Los Angeles, CA
    Try this to get your disk out.

    To eject a disc with Open Firmware commands, follow these steps:

    1. Restart the computer.
    2. Immediately after the startup sound, press and hold the key combination Command-Option-O-F.
    Note: The Command key has the Apple icon on it.
    3. Release the keys when you see a white screen that says "Welcome to Open Firmware."
    4. At the prompt, type: eject cd
    5. Press Return, then wait a few seconds. The disc drive should eject any disc that is present, and "ok" appears behind your command when the action is complete.
    6. Type: mac-boot
    7. Press Return.

    Your computer should now start up normally.
  13. aricher macrumors 68020


    Feb 20, 2004
    Happened to my Superdrive with a DVD I was burning - I tried all of the above suggestions to no avail - took it into a local Apple Store - they couldn't get it out either - sent it out for repair - back in 3 days with a new Superdrive. If it's still under warranty or Apple Care take it in.
  14. kasei macrumors 6502a


    Dec 30, 2003
    Los Angeles, CA
    Did they upgrade you from a 2X to a 4X Superdrive? If so that is pretty sweet!
  15. chw macrumors newbie

    May 4, 2004
    San Diego
    iTunes Eject

    Actually I have that happen to me this Sunday. My friend have me a disk that she burned some jpegs on. I stuck it in my Rev C. PB and nothing happened other than spinning it initially. I tried the eject button, relaunched the Finder, and hold down the mouse button during reboot and nothing worked. Then I went into iTunes and clicked on the Eject button and that solved it.

    Do you think it has to do with the fact that the disk was burned from a PC? Is this a defect that I should take it in for repair? I have tried other CDs and they all worked except for this one for some reason... :confused:
  16. OldManJimbo macrumors 6502


    Jun 1, 2004
    California Coast

    Snooziums - what ever became of this issue? Did yoiu ever get your CD to eject? Have they replaced the optical drive?
  17. snooziums thread starter macrumors regular

    Apr 30, 2004
    Evergreen State
    I tried everything. Open firmware, iTunes eject, sleep and eject, and nothing worked. I tried everything.

    Then I tried something risky. I inserted a non-sharp butter knife into the drive, pressed up on the handle, thus pressing down on the CD. The CD was forced to stop spinning. When I let up on the knife and the CD started to spin once again, the computer ejected it.
  18. Phat_Pat macrumors 68000


    May 8, 2004
    I Live Where I Live
    now thats the american way! shoving a metal object into an electric appliance while its in use! Brilliant!:p

    no but seriously nice job... i would of never done that.... that took guts my friend.... :eek:

    let's just hope it doesn't happen again.....
  19. grmyers macrumors newbie

    Jun 29, 2006

    OK, I had the same thing happen. NOTHING WORKED. I mean, I dropped it from a high height, and nothing happened.


    I am a training to be a surgeon, so I got out some Adson pickups (tweezers) and a small needle driver (not-sharp scissor-like holdy things). Open the felt with by holding the needle driver open (as in a fascial dissection) and then grab the CD with the Adsons. Yank.

    Worked for me!
  20. Vasky macrumors newbie

    Jun 29, 2006
    Is it just me or do slot drives represent the epitome of Apple placing style over functionality? How ugly would a tray be? Not very.
  21. comictimes macrumors 6502a


    Jun 20, 2004
    Berkeley, California
    It's not a matter of style (ok, not ENTIRELY a matter of style) so much as the fact that tray drives are heavier and take up more space, and apple is always trying to make their computers smaller and lighter... which I suppose is a matter of style also, but oh well...
  22. jgurol macrumors newbie

    Oct 14, 2006
    CD Stuck

    I tried all the keyboard upon boot and different things. What worked for me was holding the unit upside down and ejecting.
  23. knome macrumors 6502


    Sep 7, 2006
    In fact there is one of those. It should be on the left edge of the where you insert the cd. Just stick a paper clip in there and fish around but don't press to hard.
  24. nice marmot. macrumors newbie

    Jun 20, 2008
    eject via terminal

    To get a disk out that isn't read by the finder without rebooting:

    1. Go to your applications > utilities folder and open the terminal app

    2. In a terminal window type:

    drutil tray eject

    that should eject the disk.

    3. xtra credit: type in the terminal:

    man drutil

    to find other uses of the utility
  25. storrao macrumors newbie

    Feb 4, 2009
    this worked with me!

    i had a brand new cd stucked inside the drive (looks like it has a little bit of glue on the center!) and after reading these messages tried eject with powerbook upside down and it worked!


Share This Page