Changed RAM, now MacBook takes forever to boot, and I have no sound

Discussion in 'MacBook' started by Laika37, Mar 5, 2011.

  1. Laika37 macrumors newbie

    Joined:
    Jun 14, 2010
    #1
    So I recently upgraded my late 2009 2.26 GHz Intel Core 2 Duo Macbook to 4 GB of OWC DDR3 1067 RAM. I had never done this before, but it seemed to go without issue. I started it up and everything seemed fine. The next day it crashed, a kernel panic, I believe. I ran a memory test and there was a problem. Then it crashed again. I reset SMC, did not help. Now, however, it takes forever to load. It will get to a blue screen and sit there for 5+ minutes.

    So, I took out the memory and put in my stock 2GB. It took forever to load, but I ran a memory test and it seemed to pass. Only, now there is no sound. Under system preferences, it says "No output devices found."

    What could be the problem? Did I ruin something installing the RAM? I've run a search for these problems, but nothing has helped. Thanks so much..
     
  2. Laika37 thread starter macrumors newbie

    Joined:
    Jun 14, 2010
    #2
    I did a PRAM reset, which didn't help, and I ran Apple Hardware Test, which turned up nothing. I am running out of ideas.

    Also, I forgot to mention that with the 4GB OWC RAM, when I put it to sleep it wouldn't wake up. Since going back to stock, it seems to be functioning as normal.

    Any help is appreciated, I'm growing desperate...
     
  3. AlexMaximus macrumors 6502

    AlexMaximus

    Joined:
    Aug 15, 2006
    Location:
    A400M Base
    #3
     

Share This Page