Changing the Time Machine backup interval — Permissions issue

Discussion in 'macOS' started by mac2x, Feb 21, 2010.

  1. mac2x macrumors 65816

    Joined:
    Sep 19, 2009
    #1
    I searched MRoogle already, I didn't find anything quite like what my problem is.

    I know you can change it by editing the plist, com.apple.backupd-auto.plist. However, I am unable to save it even if I do the following:

    Code:
    LaunchDaemons $ sudo chown [my username] com.apple.backupd-auto.plist
    LaunchDaemons $ sudo chgrp admin com.apple.backupd-auto.plist
    Of course, I changed it back to root and wheel, respectively. What did I miss?

    This article, for instance, does not even mention the fact that root owns the plist!
     
  2. MacManiac76 macrumors 65816

    MacManiac76

    Joined:
    Apr 21, 2007
    Location:
    Arizona
    #2
    You could always just use TimeMachineEditor. Much simpler and you don't have to mess with plist files.
     
  3. mac2x thread starter macrumors 65816

    Joined:
    Sep 19, 2009
    #3
    Thanks, but I have a feeling that that app is doing exactly what I want to do. If I could figure out what I missed, I wouldn't need another app to do something I can already do. ;)

    OT: How do you like that WD Scorpio Blue in your MBP?
     
  4. MacManiac76 macrumors 65816

    MacManiac76

    Joined:
    Apr 21, 2007
    Location:
    Arizona
    #4
    OK well I just tried changing the permissions using the Get Info window for the file and it didn't work that way either. The only way I got it to let me update the file and save it was using the pico editor in Terminal.

    Code:
    LaunchDaemons $ sudo pico com.apple.backupd-auto.plist
    Then edit the interval line and save the file. It worked for me doing it that way.


    OT: So far the WD Scorpio Blue has been working like a dream. No problems at all and very quiet. I try to put my ear up to it and all I ever hear is the cpu fan. It's pretty quick for a 5400 rpm drive. I have only had it a couple weeks so we'll see if all keeps going well. I know others have experienced some problems with the drive, but from what I've seen it's been mostly on unibody MacBooks and MacBook Pros. I actually have a white MacBook from early 2008 just before the unibodies came out. Other than the crappy Intel graphics I absolutely love it and it runs like a dream.
     
  5. mac2x thread starter macrumors 65816

    Joined:
    Sep 19, 2009
    #5
    Thanks, I'll give that a whirl. :)


    Thanks for the info on your drive! I plan to get a new one for my MBP this summer and do a fresh SL install on it, and then move my data over from the Leopard volume via an enclosure and Migration Assistant. I have my eye on one of these two drives because I want more speed, and they seem to be quite efficient for the the few times I need to run off battery.
     
  6. mac2x thread starter macrumors 65816

    Joined:
    Sep 19, 2009
    #6
    I was able to edit successfully with pico; now to watch it and make sure nothing screwy happens.
     
  7. mac2x thread starter macrumors 65816

    Joined:
    Sep 19, 2009
    #7
    It didn't work; TM backed up on the hour. :( I think I'll just leave it hourly for now.
     
  8. MacManiac76 macrumors 65816

    MacManiac76

    Joined:
    Apr 21, 2007
    Location:
    Arizona
    #8
    Did you turn Time Machine off and then back on again after making the change? Also reading the article you linked to in the OP one user suggested reselecting the drive you want to use for Time Machine in the preferences if just turning it off and on doesn't work.
     
  9. mac2x thread starter macrumors 65816

    Joined:
    Sep 19, 2009
    #9
    Nah, I didn't. :eek: My TM volume is a thumbdrive ATM (I only back up my volatile files) and it needs to be erased and started over, so I'll give it a try.
     

Share This Page