Clamshell mode via HDMI, no sound due to lack of dGPU?

Discussion in 'MacBook Pro' started by GP20, Mar 2, 2014.

  1. GP20 macrumors member

    Joined:
    Oct 3, 2012
    #1
    I have a late 2013 rMBP 15 without a dGPU. I connect it to my TV via HDMI. I also have an Apple bluetooth trackpad connected. When the lid/screen is open, the sounds comes out from the TV just fine. But when I close the lid to make it go into clamshell mode, video continues to play on TV, but audio switches to the rMBP's speakers and no sound comes out from the TV.

    Now when I use my friend's late 2013 rMBP 15 WITH the dGPU to do testing, using the same TV and same HDMI cable, even after I put his rMBP in clamshell mode, the sound continues to come out from the TV.

    Am I correct in assuming that the lack of dGPU is what causes the audio to switch back to the rMBP's speakers after it goes into the clamshell mode?

    Or is there some other setting I can change or is there something wrong with my rMBP?

    Thanks in advance!
     
  2. jt.syrja macrumors newbie

    jt.syrja

    Joined:
    Apr 21, 2013
    Location:
    Finland
    #2
    I suppose every macbook has different settings for different setups. I mean when you connect your amcbook to an external monitor you can go to audio settings and select correct audio output. then when tou close your lid your setup kinda changes and maybe you need to go to audio settings and select correct output for that setup too. I think these setting will be saves so no need to go select every time...

    not sure if this helps...
     
  3. GP20 thread starter macrumors member

    Joined:
    Oct 3, 2012
    #3
    Thanks for the reply.

    On my rMBP, after I closed the lid, I did go to System Preferences > Sound > Output. However, the HDMI option was no longer there (it was there when the screen lid was open). The only option was Internal Speakers.

    On my friend's rMBP, after I closed the lid, in Sound Output, the HDMI option was still there and audio was coming from the TV just fine.
     
  4. Fimeg macrumors regular

    Joined:
    Jun 12, 2013
    #4
    This problem could easily be related to a poorly manufactured HDMI Cable, or to a 2009 Macbook Pro which was never supported. Given that my rMBP (2012) works just fine, I'd wager it could be the cable.
     
  5. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #5
    Having that option disappear is not normal and shouldn't have anything to do with clamshell mode. Either you are using a faulty cable or adapter, or your mac has some kind of problem.
     
  6. GP20 thread starter macrumors member

    Joined:
    Oct 3, 2012
    #6
    It was the same HDMI cable and same TV. We tested the 2 rMBP's back to back and repeatedly.

    ----------

    But does your rMBP have a dGPU? Like I mentioned in my original post, I'm trying to find out whether my late 2013 rMBP's lack of dGPU is the cause for the audio switching back to internal speakers in clamshell mode.
     
  7. Justinhub2003 macrumors regular

    Joined:
    Jul 17, 2012
    Location:
    Cincinnati Oh
    #7
    on my old 2011 13" MacBook Pro with no dedicated GPU, I had no issue with HDMI Audio going through TV in clamshell mode. So I dont dedicated GPU has anything to do with it.
     
  8. accountforit macrumors 6502a

    Joined:
    Jan 22, 2014
    #8
    Doesn't it need to be plugged into AC power as well?
     
  9. GP20 thread starter macrumors member

    Joined:
    Oct 3, 2012
    #9
    I ended up doing a fresh install of Mavericks and the audio was now working via HDMI to TV in clamshell mode.

    Thank you all for the the replies!:D
     

Share This Page