classic won't start after upgrading to panther

Discussion in 'Mac Apps and Mac App Store' started by taeclee99, Nov 22, 2003.

  1. taeclee99 macrumors 6502a


    Jun 4, 2002
    Anywhere but here
    I upgraded to panther couple weeks ago and I thought everything was fine. Until I launched a classic app. When classic launches, I get this message:

    "there is a problem with updating the classic-specific files.

    Classic was unable to update its files in "System Folder" on Macintosh HD"

    Classic then quits.

    I am however able to boot into OS9 from the startup. I am unsure what to do about this.

    Do I need to reinstall the classic environment? Anyone else experience this problem?

    Thanks in advance
  2. Nermal Moderator


    Staff Member

    Dec 7, 2002
    New Zealand
    I've never had this problem before, but try repairing permissions. Also, open up Classic Preferences and choose Rebuild Desktop from the Advanced tab.
  3. FredAkbar macrumors 6502a


    Jan 18, 2003
    Santa Barbara, CA
    Yeah sounds like a permissions issue. You might be able to fix it by Getting Info on the System Folder and making sure your system has read/write capabilities on it. After that, repair permissions as Nermal said.
  4. Mori macrumors newbie

    Jan 28, 2004
    Classic still won't update

    I have the same trouble as taeclee99. I've tried the fixes suggested (fixing permissions through disk utility, rebuilding the desktop and making sure the system folder allows read/write) but still can't launch classic.

    As a last resort I tried replacing the classic files with those from the OS 9 system folder of another Mac that does run classic and trashing the OS 9 classic preferences. Still won't work.

    Any other ideas?
  5. jxyama macrumors 68040


    Apr 3, 2003
    this may not pertain exactly to the problem at hand, but...

    how did you install panther? if you wiped your HD clean, then classic will basically be gone - panther disc only contains OS X.3. (easiest way to check is to look at your HD - do you see "Applications (Mac OS 9)" folder there?)

    the rationale is that the classic (or OS 9.2.2) came with your initially purchased Mac. the price of panther doesn't include OS 9.2.2, your original Mac does.

    if you are like me and upgraded from Jaguar to Panther, go get the original disc of the Mac containing Jaguar. using that CD, you can install Classic support by installing OS 9.2.2. (this doesn't mean you'll be able to boot OS 9.2.2, it just means it will be booted when Classic is launched.)
  6. Mori macrumors newbie

    Jan 28, 2004
    Classic now works

    Can't take credit for this--I got the idea from a post on another forum--but the answer for me was to replace the Classic Startup file, located in System/Library/Core Services. I fortunately had another Mac that was able to run Classic, and copied the file from that Mac. After jumping a few authorization hoops (I logged in as root on both machines) I was able to replace the bad Classic Startup with the new one, then repaired the disk permissions with Disk Utility (very important).

    Here's a link--go to the second to the last message and hit that link:

Share This Page