Code signing is required for product type…

Discussion in 'iOS Programming' started by bristleworm, Dec 8, 2010.

  1. bristleworm macrumors 6502

    bristleworm

    Joined:
    Jul 22, 2008
    Location:
    Germany
    #1
    Hi.

    I recently started checking out programming for iOS devices. Since I just wanted to see if it could be fun for me, I haven't yet signed in to the paid developer programs.
    I just finished a little test game and wanted to run it in the iPhone Simulator (something I believe should be working without being an official iPhone developer).

    But everytime I hit "Build and Run", I get this error:
    "CodeSign error: code signing is required for product type 'Application' in SDK 'iOS 4.2'"

    Any help would be greatly appreciated!
    Thanks in advance!
     
  2. zachsilvey macrumors 6502

    Joined:
    Feb 5, 2008
    Location:
    Battle Ground
    #2
    Sounds like you have the drop down option in the top left hand of Xcode set to 4.2 device instead of simulator. Either that or you have changed something in the distribution settings in the build settings.
     
  3. bristleworm thread starter macrumors 6502

    bristleworm

    Joined:
    Jul 22, 2008
    Location:
    Germany
    #3
    Thanks for the quick answer. This solved my problem. If I ever finish something I make available on the App Store, I'll post it here. :)
     
  4. dejo, Dec 8, 2010
    Last edited by a moderator: Oct 15, 2017

    dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #4
    Just be sure to post about it in the right forum (see Guidelines for Software Developers) and not here in the iPhone / iPad Programming forum. :D
     

Share This Page