Compatibility for 10.14 Mojave

Herman Hamm

macrumors newbie
Original poster
Jan 1, 2018
14
3
Bellingham, WA
I have an iMac running latest High Sierra 10.13.6 Here are specs from 'About this Mac'
27-inch, late 2013 (manufacture)
Processor 3.2 GHz Intel Core i5
Memory 8 GB 1600 MHz DDR3
Graphics NVIDIA GEFORCE GT 755M 1024 MB

Shouldn't this hardware support Mojave? I have had no automatic updates come down yet to me for installing this? Should I just go to the App Store and download it? I believe it is a free download.

Thanks for all help and assistance
Herman
 

Herman Hamm

macrumors newbie
Original poster
Jan 1, 2018
14
3
Bellingham, WA
Thank you very much for a quick response and for good news. I will go to the App Store and download 10.14. I check the store everyday for updates anyway to existing software, so updates are no problem.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.