connecting Canon XL1s to the Powerbook g4 12" question

Discussion in 'Mac Apps and Mac App Store' started by gallagb, Aug 8, 2004.

  1. gallagb macrumors 6502


    Apr 28, 2004
    ok i've got a powerbook g4 12"
    the new one

    and i've got a canon XL1s
    and iMovie and Final Cut Express

    and when i plug the camera into the computer the computer doesn't 'read' the camera!

    imovie help said to re-set the clock on the camera- did that
    imovie help said to re-cycle the power in the camera...etc- did that

    still no game?!

    i've got some video on the camera i wanna upload- but i'm clearly not having the luck i need to get this done-
    any clues?
    what am i missing?
    what am i doing wrong?

  2. ChrisFromCanada macrumors 65816


    May 3, 2004
    Hamilton, Ontario (CANADA)
    3 Suggestions:

    1. Check all cords for loose connections.

    2. Restart your computer (maybe repair permissions)

    3. Check to see if any other cameras will connect to the pb
  3. LeeTom macrumors 68000


    May 31, 2004
    Did you turn the camera on? Is it plugged into the wall for power?
    Try using Final Cut Express instead of iMovie and see if you get different results.

    Lee Tom
  4. tdhurst macrumors 601


    Dec 27, 2003
    Phoenix, AZ

    You bought a Canon XL-1 to use with iMovie? Lil overkill, ya think?
  5. Nspace macrumors regular

    Jul 13, 2004
    Toronto, Canada
    I have never done editing on my Apple yet, but I have done it with pcs at school. Alot of Capturing from a GL1. I think I did capture in iMovie once when Adobe Premiere had no osx support. Make sure the camera is in vcr mode, and not record mode.

    From what I know it should be detected by the computer and you should be able to capture via 1394 in any of the above programs you mentioned.

    Weird problem, real nice video camera you have there too!
  6. Nspace macrumors regular

    Jul 13, 2004
    Toronto, Canada
    Well he did say he was planning to use FCP Express.
  7. gallagb thread starter macrumors 6502


    Apr 28, 2004
    YIKES- and they all jump on me

    ok- NOT my camera
    i don't have another camera
    not my project- i'm just doing this for a friend of mine-

    YES - i have both iMovie and Final Cut Express
    i was going to use FCE - however it didn't work- so i tried iMovie
    (yes- i agree that it was overkill)

    everything was plugged in correctly
    the camera had wall power
    the firewire cord went from the PB into the mini-jack on the camera

    the error that followed w/ imovie was just a blank blue screen which said "no camera input" or something like this- then had a button that sent me to iMovie help- they suggested i cycle the power (as you have suggested) and also that i re-set the clock on the camera- which i did

    FCE- said (while using the simple setup window) that no firewire input was located

    MEANWHILE_ in the camera view-finder- once i plugged in the Firewire cable- it said something about the presence of a DV-link

    Further- the camera WAS in VCR mode- (which is the only viewing of video mode that i know of)

    so no- i'm not totally retarded and no i haven't spent any $ on this project

    (well- i own FCE- but it was $99 w/ the purchase of my sister's new laptop and mom/dad were willing 2 buy it for me- and as the poor grad student that i am w/ virtually no video interest currently but some in the past - i couldn't resist accepting the gift)

    ALSO ran repair permissions - per suggestion- still nada-
    FCE says: unable to locate external devices (which i have selected as an apple firewire NTSC device)
  8. RBMaraman macrumors 65816


    Jul 25, 2002
    Prospect, KY
    Make sure you have the camera plugged into the computer (via FireWire) BEFORE you open iMovie. Sometimes, iMovie will not detect a camera if it's plugged in after the program is opened.

    Do this:
    1. Restart your computer.
    2. Plug the FireWire cable into the camera with the camera on and in VCR mode.
    3. Open iMovie.

    If it's still not recognized, give Apple Tech Support a call. Your FireWire bus may be dead. Do you have any other FireWire devices (iPod, external hard drive, digital camera) to test the port?
  9. jemeinc macrumors 6502a

    Feb 14, 2004
    South Jersey
    Yeah, what's your point ?... C'mon man, if you can help, help... If not stop judging people with smart ass remarks... Seems like there's a lot of this lately, it's a shame...
  10. gallagb thread starter macrumors 6502


    Apr 28, 2004
    firewire port works
    i use an iSight and an iPod as well as a separate external firewire drive in it regularly

    however- i'll try that exact order you prescribed later this evening -
    any other ideas?

    (when i call apple support what do i ask for?- i've never called them before...etc)

    thanks for the help!
    & jemeinc - thanks for retorting that mean comment that was tossed my way! - i agree there seems to be an attitude of posts lately -- i've noticed some posts lately that say "don't call me stupid, but here's my prbm..."
    we shouldn't have to preface our questions with a disclaimer like that
    we all know- since we are using mac's we're not stupid
    or...mostly not stupid.
  11. gallagb thread starter macrumors 6502


    Apr 28, 2004
    HA firewire port DOES NOT work
    it feeds power to the divices (named above) but doesn't load /mount it looks like it works- but does not

    (figured this out today)

    after a quick stop @ the genius desk and a good long chat w/ the applecare folks we've decided the logic board is trashed

    so- apple will send me a box tomorrow(ish) to have that fixed
    they recommend i backup my harddrive
    (will be tough w/o a firewire port...)
    but i'll get on that tonite-

    thanks for the thoughts from everyone though!

Share This Page