Contacts coming up as phone numbers instead of name in messenger

Discussion in 'iOS 5 and earlier' started by bjackson2718, Oct 13, 2011.

  1. bjackson2718 macrumors newbie

    Joined:
    Sep 13, 2010
    Location:
    Silicon Valley
    #1
    I'm only having this problem with contacts who I've used iMessenger with. At the top of the message it shows their phone number rather than their name. The phone number that appears is the same as the one in the contact info 1(xxx)-xxx-xxxx

    How do I get it so their name appears? Running iOS5 on iPhone 4. NOT a problem with SMS, just contacts with iMessenger. Help me!
     
  2. dccorona macrumors 68020

    dccorona

    Joined:
    Jun 12, 2008
    #2
    can't confirm this myself, but people with this issue are claiming a restart of the phone fixes it
     
  3. bjackson2718 thread starter macrumors newbie

    Joined:
    Sep 13, 2010
    Location:
    Silicon Valley
    #3
    In my 30 minutes trying to find a solution via Google, that wasn't mentioned. I just tried turning it off and back on and it worked. Thanks!
     
  4. motherpucker7 macrumors newbie

    Joined:
    Mar 31, 2012
  5. Zavior macrumors newbie

    Zavior

    Joined:
    Aug 16, 2008
    Location:
    Denmark - EU
    #5
    I'm also having this problem on my new iPad 3.

    All phone numbers showing instad of names in iMessage on the iPad.

    I found it to be related to how iOS shows contacts.

    On my iPad running iOS 5.1 all my contacts is shown like this:
    (###) ###-##

    How it should be:
    ## ## ## ##

    And the reason why iMessage won't show names like it should.
    If I add country code +45 on all my contacts it works with names.

    Can't seem to find any setting in iOS to fix this. Have been looking in International settings without luck. Any help would be great!
     
  6. PNutts macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #6
    Mine are all 10 digit numbers and it works. Other's reported having to put a "1" or "+1" number in front of their contacts' numbers to make it work.
     

Share This Page