Contacts not showing up in spotlight search but showing in the contacts app

Discussion in 'iOS 10' started by wannabelean, Dec 28, 2016.

  1. wannabelean macrumors 6502

    Joined:
    Mar 18, 2009
    #1
    Is this a known bug? Are there any workarounds or temp fixes to this? Its too much effort to open up the contacts app every single time and search for the contact. Any help would be greatly appreciated. Thanks in advance.
     
  2. gigapocket1 macrumors 6502a

    Joined:
    Mar 15, 2009
    #2
    I haven't heard of this issue. My issue is that when a search for a contact it pops up. But when I click it. It's a blank contact card. Have to go in and out 3-4 times for it to eventually work.
     
  3. Abazigal macrumors 604

    Abazigal

    Joined:
    Jul 18, 2011
    Location:
    Singapore
    #3
    I do not think it is a bug, but some apps can take a very long time to be indexed by spotlight, especially if you have a lot of apps set to be indexed in this manner. It's possible that spotlight froze somehow and simply never got round to indexing your contacts.

    What I did was to turn off every app that I knew I would need to be searched , leaving only a few core apps to be searched and indexed by spotlight.

    [​IMG]

    Here's an example of my settings. I have about 56 apps indexed, out of over 100 apps installed. You can probably get that number way down if you are more selective.

    That should help speed up your contacts being indexed by spotlight.
     
  4. wannabelean thread starter macrumors 6502

    Joined:
    Mar 18, 2009
    #4
    Gigapocket1 - that's another issue I have that keeps up coming intermittently.

    Abazigal - I already did this bro. I only have contacts enabled. Disabled/enabled few times and still no luck.
     
  5. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #5
    Is this true for all contacts or just some? Is there a particular "Group" that is troublesome (syncing source of the contacts)?
     

Share This Page