iPhone 7(+) Contacts won’t sync

Discussion in 'iPhone' started by RealtorRob, Mar 18, 2018.

Tags:
  1. RealtorRob macrumors newbie

    RealtorRob

    Joined:
    Oct 17, 2015
    #1
    Hi,
    Recently got a new iPhone and my contacts did not sync from my iPad to my iPhone. I have about 100 contacts in iPad and on 50 on iPhone.
    Thanks for help.
     
  2. mikzn macrumors 65816

    mikzn

    Joined:
    Sep 2, 2013
    Location:
    Vancouver
    #2
    Do you also have a MAC? do you have contacts there also?

    You can log into iCloud.com and see how many contacts are on iCloud - this can be helpful to make sure you know which location has the most contacts before you start signing out of Contacts (and back in) on any of the devices to reset the Sync.

    Since your iPad has more contacts make sure these contacts are also on the icloud.com version?
     
  3. RealtorRob thread starter macrumors newbie

    RealtorRob

    Joined:
    Oct 17, 2015
    #3

    No, Mac. I checked on icloud, I have 80 contacts in icloud and 80 contacts on my phone, but my ipad has way more.
     
  4. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #4
    Are you seeing duplicates? If so, delete them and do an iCloud backup.
     
  5. RealtorRob thread starter macrumors newbie

    RealtorRob

    Joined:
    Oct 17, 2015
    #5
    I don’t have any duplicates on my iPad. I’m also not getting text Masseges on my iPad either. Under accounts send and receive text messages listed is a gmail account my phone number and my iCloud account.
     
  6. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #6
    If your Gmail account is not your AppleID account, that is why you aren't receivijng texts etc. The first account under the sent and receive text messages should be your iPhone number followed by your Apple ID email account, and any other email that is directly linked to and associated with your AppleID email account.
     
  7. RealtorRob thread starter macrumors newbie

    RealtorRob

    Joined:
    Oct 17, 2015
    #7
    Ok, so I had my phone number followed by my gmail account and then my Apple ID. I unchecked the gmail account, I never got text messages from gmail either tho.
     
  8. mikzn macrumors 65816

    mikzn

    Joined:
    Sep 2, 2013
    Location:
    Vancouver
    #8
    So your iPad has the best contact list and you need to be careful you do not lose them. Also you need to get them uploaded / synced to iCloud.com

    First you can review your iPad Settings here - Get help using iCloud Contacts, Calendars, or Reminders
    it might be good to confirm what iOS you have on the iPad so that any advice from forum members is correct - different version of iOS have different settings.
    "On your iPhone, tap Settings > [your name] > iCloud. (If you're using iOS 10.2 or earlier, tap Settings > iCloud.) Check your Apple ID and make sure that you turn on what you want to update (Contacts, Calendars, or Reminders)."

    Contacts - Check out this section on the link above - "Set iCloud Contacts, Calendars, or Reminders as your default"

    For Messages (ipad) - check in settings < messages and make sure your phone, apple ID and email are all included and that at the bottom of the page - "Start new conversations from" is your phone number.
    More info here - Use Messages on your iPhone, iPad, or iPod touch
     
  9. RealtorRob thread starter macrumors newbie

    RealtorRob

    Joined:
    Oct 17, 2015
    #9
    --- Post Merged, Mar 22, 2018 ---
    So, I put gmail back on my iPhone and then most of my contacts came back. So is gmail storing my contacts?
     
  10. RealtorRob thread starter macrumors newbie

    RealtorRob

    Joined:
    Oct 17, 2015
    #10
    Any ideas?
     
  11. BrianBaughn macrumors 603

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #11
    It could be. You can select "Groups" at the top of the page in Contacts to turn individual groups on and off. That ought to tell you where things are.
     
  12. RealtorRob thread starter macrumors newbie

    RealtorRob

    Joined:
    Oct 17, 2015
    #12
    That’s for the reply. But still no help.
     

Share This Page

11 March 18, 2018