Cool little trick/discovery! (Double-tap to zoom, even if it's turned off.)

Discussion in 'Mac OS X Lion (10.7)' started by iBreatheApple, Sep 21, 2011.

  1. iBreatheApple macrumors 68020

    iBreatheApple

    Joined:
    Sep 3, 2011
    Location:
    Florida
    #1
    I know many of you are like me and hated the "lag" when "right clicking" in Lion so you probably turned double tap to zoom OFF which fixes the issue. I have discovered that even if this feature is off, if you spread your two fingers apart as if you had just zoomed in, double tap with your fingers in that position and you still get double tap to zoom. Pretty neat!

    Sorry if that's confusing, it's hard to explain. Try taking your index and ring finger and placing them at the bottom left and top right of the touchpad and double tap. Voilà!
     
  2. ceej macrumors member

    Joined:
    Aug 28, 2011
    Location:
    Northeast United States
    #2
    You can use two fingers in any form as long as they tap the pad at the same time, haha.
     
  3. iBreatheApple thread starter macrumors 68020

    iBreatheApple

    Joined:
    Sep 3, 2011
    Location:
    Florida
    #3
    No, not if the feature is not turned on. And many people like this feature OFF as it "lags" the right click menu so it has time to recognize the input.
     

    Attached Files:

  4. Patrick J macrumors 65816

    Patrick J

    Joined:
    Mar 12, 2009
    Location:
    Oporto, Portugal
  5. ceej macrumors member

    Joined:
    Aug 28, 2011
    Location:
    Northeast United States
    #5
    You can't be disagreeing with both of us. He was doing it, so he's right because it does work. I was just telling him that it doesn't matter where those two fingers are when you do it.
     
  6. iBreatheApple thread starter macrumors 68020

    iBreatheApple

    Joined:
    Sep 3, 2011
    Location:
    Florida
    #6
    Your quote was: "You can use two fingers in any form as long as they tap the pad at the same time, haha.

    That is incorrect because if you try tapping like you are "supposed" to (when the feature is on) it will not work.
     
  7. baryon macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #7
    Awesome!

    Those of you who don't get it: Two-Finger-Double-Tap-to-Zoom introduces a very annoying lag to Two-Finger-Single-Tap-to-Right-Click, as the gesture is waiting for the second tap to happen or to not happen to decide between single and double tap.

    However, even when turning the two-finger-double-tap-to-zoom gesture off, you can still two-finger-double-tap if your two fingers are further away from each other.
     
  8. declandio macrumors 6502

    Joined:
    Apr 3, 2009
    Location:
    London, UK
    #8

    ... I have two finger double tap to zoom enabled and there's no lag when double tapping to right click.
     
  9. baryon macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #9
    So, as you lift your fingers, the right-click menu is already there? Don't you have to wait about half a second?
     
  10. declandio macrumors 6502

    Joined:
    Apr 3, 2009
    Location:
    London, UK
    #10
    No, I don't!
     
  11. iBreatheApple thread starter macrumors 68020

    iBreatheApple

    Joined:
    Sep 3, 2011
    Location:
    Florida
    #11
    Either it's off and you don't know it, or you've never experienced it with it off. Turn double tap to zoom off real quick and then right click, it's much quicker, almost instant. And, you are using some sort of trackpad, right? Not a mouse?
     
  12. baryon macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #12
    Well in that case, if you double tap with two fingers to zoom, the menu will appear even if your intention was to zoom and not right-click, which would look a bit strange wouldn't it? I'm sure that's not the case...
     
  13. declandio macrumors 6502

    Joined:
    Apr 3, 2009
    Location:
    London, UK
    #13
    Sorry- I can't replicate the problem you seem to be having. Double tap quickly to zoom, and it zooms. Two fingers to right click, and it right clicks.
     
  14. iBreatheApple thread starter macrumors 68020

    iBreatheApple

    Joined:
    Sep 3, 2011
    Location:
    Florida
    #14
    Ay yi yi.
     
  15. Benbikeman macrumors 6502a

    Benbikeman

    Joined:
    May 17, 2011
    Location:
    London, England
    #15
    Ditto here. No visible lag.

    I'm guessing this is to do with the double-click speed you have set in trackpad settings.
     
  16. ceej macrumors member

    Joined:
    Aug 28, 2011
    Location:
    Northeast United States
    #16
    You're just jealous that ours works properly in any fashion. It's alright.

    ----------

    Oh snap, a WHOLE half of a second? Call the authorities, 2011 is having a techgasm.
     
  17. iBreatheApple thread starter macrumors 68020

    iBreatheApple

    Joined:
    Sep 3, 2011
    Location:
    Florida
    #17
    WOW I wish this forum permitted "name-calling" because you deserve it. Are you that dense? I'm jealous? First of all this thread has NOTHING to do with anything "not working" because everything I've states is exactly how it is supposed to work. It's about my find. You have no idea what you're talking about. Lastly, let's raise the maturity bar a few notches. What, you found out you were wrong and now you have nothing to say except "call the authorities"? Nice.
     
  18. bully worm macrumors regular

    Joined:
    Sep 17, 2009
    #18
    Calm down broskis. Let's be civilized here.

    As far as the issue is concerned, I'm not seeing any lag either. It probably has to do with individual machines. I'm glad the fix you found is working for you. Always nice to have problems that are accompanied by a fix.
     
  19. iBreatheApple thread starter macrumors 68020

    iBreatheApple

    Joined:
    Sep 3, 2011
    Location:
    Florida
    #19

    Lol.

    It's not a fix, more of a "feature". Try this for me if you have the time. Right click with two fingers on a trackpad and note the time. Now, turn double tapping to zoom OFF and try right clicking now. Note the difference. Nobody cares about it so much so that it's a problem **coughCEEJcough**, it's just I'll sacrifice smart zoom for the quickness of right clicking. That's where this thread comes to play, it's just a cool thing I found you could do even if you have the feature is off.
     
  20. redache macrumors member

    Joined:
    Sep 16, 2011
    #20
    I've tried it both with Double Tap To Zoom off and on and I really can't see a difference in responsiveness on a right click.
     
  21. bully worm macrumors regular

    Joined:
    Sep 17, 2009
    #21
    Well...I see what you're saying. There's about a half-second delay. Though spreading my fingers apart and double-tapping isn't zooming in for me.

    Edit. NVM it does. Well thats pretty neat. I guess I'll leave it unchecked then. Thanks for the tip.
     
  22. iBreatheApple thread starter macrumors 68020

    iBreatheApple

    Joined:
    Sep 3, 2011
    Location:
    Florida
    #22
    :)
     
  23. tkermit macrumors 68030

    tkermit

    Joined:
    Feb 20, 2004
    #23
    Experiment a bit with how slowly you can double tap so that it is still recognized as a smart zoom gesture. The maximum amount of time that is allowed to pass between the first and the second tap is exactly the lag that you will experience when right-clicking once with two fingers.
     
  24. Benbikeman macrumors 6502a

    Benbikeman

    Joined:
    May 17, 2011
    Location:
    London, England
    #24
    I'd put money on it being the trackpad setting for double-tap speed. I'm not seeing any noticeable lag at all on right-click - maybe 1/10th of a second. But I double-tap quickly so have that set to a fast speed.

    The OP is reporting a 1/2-second lag, massively different to what I'm seeing, so that's the most likely explanation.
     
  25. ceej macrumors member

    Joined:
    Aug 28, 2011
    Location:
    Northeast United States
    #25
    Why on earth did you take that seriously? Hahahahahahaha. Grow a funny bone, guy.
     

Share This Page