Corrupted and unreformattable Maxtor OneTouch hard drive

Discussion in 'Macintosh Computers' started by mikko2004, Oct 7, 2004.

  1. mikko2004 macrumors newbie

    Aug 12, 2004
    I own a 250 GB Maxtor OneTouch drive (the USB/FireWire model), and used it with the original FAT32 formatting (for occasional PC use). First I used it with my old iMac (OS9.1), and it worked ok but later started to become slow, despite less than 50 GB of files on the drive. Finally it stalled and I had to disconnect it without unmounting it via the Finder. I was able to recover the files with a PC based utility, and then formatted it to Mac Extended format.

    Later, when making an iDVD archive copy from my brand new PowerBook 12 running OS X 10.3, the archiving process stalled. After that, the drive has been a pain. I have tried to reformat it with the Apple Disk Utility. Sometimes it works, sometimes it reports errors. Disk Verify always reports all kinds of errors, even after a succesful formatting (invalid B-tree nodes etc.). I have tried reformatting it on iMac, PowerBook and PC. I have tried formatting to different formats, partitioning etc. Yesterday I was able to create ten 24GB partitions but only a few of them mounted and then they started behaving erratically. Subsequent reformats and re-partitionings failed.

    The product is still under warranty but the nearest warranty site is 2000 km away.

    Does anybody have an idea what went wrong and what to do?

    - Mikko
  2. hotwire132002 macrumors 65816


    Jan 24, 2004
    Cadillac, MI
    I had a similar problem one time. It was caused by a faulty drive. I would say to send in the drive and get it exchanged. A pain, I know, but better than data loss!

Share This Page